WV-ASF900

PCソフトウェアパッケージ WV-ASF900

・ このファイルをよくお読みの上、正しくお使いください。お読みになったあとは大切に保管し、必要なときにお読みください。

・ このファイルは管理者による管理をお勧めします。一般の利用者に開示するとセキュリティが損なわれる可能性があります。

【重要】予期しない電源断によるWindowsのシステムダウン時には、データベースの破損により顔検索、顔照合などの機能が動作しなくなる場合があります。UPS（無停電電源装置）などの利用を推奨します。

概要

はじめてお使いになる前に

新規構築時の手順

システム運用開始後の設定変更手順

トラブルシュート

オープンソースソフトウェア


概要

PCソフトウェアパッケージ WV-ASF900 (以降、本ソフトウェアと略します)は、市販のパーソナルコンピュータ(以降、PCと略します)上にインストールして使用します。

本ソフトウェアをインストールしたPC(以降、本機と略します)は弊社製の指定ネットワークカメラにて撮影された人物の顔画像を受信し、顔のサムネイル画像および、顔の特徴情報をデータベースに蓄積します。

本機に対応したクライアント端末からの操作により、特定の人物と照合された場合のアラーム通知や特定の人物を検索することなどができます。

商標および登録商標について

免責について

著作権について

ネットワークに関するお願い

個人情報の保護について


商標および登録商標について

・ Microsoft、Windows Serverは、米国Microsoft Corporationの米国およびその他の国における登録商標または商標です。

・ Intel、インテル、Intel Core、Xeonは、米国およびその他の国におけるIntel Corporationの登録商標または商標です。

・ Adobe、Adobeロゴ、およびReaderは、Adobe Systems Incorporated（アドビシステムズ社）の米国ならびに他国における登録商標または商標です。

・ その他、本文中の社名や商品名は、各社の登録商標または商標です。


免責について

・ 本製品は、ネットワークカメラで撮影された顔画像から、顔の特徴情報およびサムネイル画像をデータベースに蓄積し、本製品に対応したクライアント端末またはシステムからの操作により特定の顔の検索／照合、および統計情報を表示する目的で作られています、本製品単独で犯罪などを防止するものではありません。

・ 弊社は、いかなる場合も以下に関して一切の責任を負わないものとします。

（１）本製品に関連して直接または間接に発生した、偶発的、特殊、または結果的損害・被害

（２）お客様の故意や誤使用、不注意による障害または本商品の損傷など

（３）お客様による本商品の逆コンパイル、逆アセンブルが行われた場合、それに起因するかどうかにかかかわらず、発生した一切の故障または不具合

（４）ＰＣに保存された画像データ、音声データ、設定データの消失あるいは漏えいなどによるいかなる損害、クレームなど

（５）ネットワーク上からの不正アクセスなど悪意を持った第三者による画像データ、音声データ、認証情報（ユーザー名、パスワード）の漏えいなどによるいかなる損害、クレームなど

（６）お客様による監視画像（記録を含む）が何らかの理由により公となりまたは使用され、その結果、被写体となった個人または団体などによるプライバシー侵害などを理由とするいかなる賠償請求、クレームなど


著作権について

本製品に含まれるソフトウェアの譲渡、コピー、逆アセンブル、逆コンパイル、リバースエンジニアリングは禁じられています。また本製品に含まれるすべてのソフトウェアの輸出法令に違反した輸出行為は禁じられています。


ネットワークに関するお願い

本機はネットワークへ接続して使用するため、以下のような被害を受けることが考えられます。

①本機を経由した情報の漏えいや流出

②悪意を持った第三者による本機の不正操作

③悪意を持った第三者による本機の妨害や停止

このような被害を防ぐため、お客様の責任の下、下記のような対策を含め、ネットワークセキュリティ対策を十分に行ってください。

・ファイアウォールなどを使用し、安全性の確保されたネットワーク上で本機を使用する。

・コンピュータが接続されているシステムで本機を使用する場合、コンピュータウイルスや不正プログラムの感染に対するチェックや駆除が定期的に行われていることを確認する。

・画像データ、認証情報（ユーザー名、パスワード）、アラーム情報、機器情報などをネットワーク上に漏えいさせないため、それらの情報を格納しているサーバーや各種接続機器に対してユーザー認証でアクセスを制限するなどの対策を実施する。


個人情報の保護について

本機を使用したシステムで撮影された本人が判別できる情報は、「個人情報の保護に関する法律」で定められた「個人情報」に該当します。※

法律に従って、映像情報を適正にお取り扱いください。

※ 経済産業省の「個人情報の保護に関する法律についての経済産業分野を対象とするガイドライン」における【個人情報に該当する事例】を参照してください。


はじめてお使いになる前に

機能概要

システム機器構成

システム仕様

推奨動作環境


機能概要

本ソフトウェアは、本ソフトウェアに対応したクライアント端末またはシステムでの操作により各機能を利用します。

主な機能は以下の通りです。

①リアルタイム顔照合アラーム機能・・・本ソフトウェアに事前に登録した顔画像と類似した人物をネットワークカメラが捉えるとアラームを通知します。

②顔検索機能・・・本ソフトウェアに蓄積した顔画像データから指示した顔画像と類似した顔画像を検索し、表示します。

③統計情報表示・・・指示した期間で性別、年代で区分した人数を表示します。

具体的な操作については本ソフトウェアに対応したクライアント端末またはシステムの取扱説明書を参照してください。


システム機器構成

本システムは管理機能を持つブローカーノード（Broker Node）と、映像を受信し顔照合を行うフェイスマッチングノード（Face Matching Node、FM Nodeと略します）で構成されます。

Broker Nodeとして動作するPCはFM Nodeとしても動作させ、そのPCをマスターサーバーと呼び、FM Nodeとしてのみ動作するPCをスレーブサーバーと呼びます。

注）上記のシステム機器構成は一例であり、使い方によりシステム構成は異なります。


システム仕様

接続可能なネットワークカメラ台数： FM Node 1台につき最大20台

    注) WV-ASF900にはネットワークカメラ 4台のライセンスしか含まれておりません。

        5台以上のネットワークカメラを接続する場合、WV-ASFE901(カメラ拡張キット/1台)、

        WV-ASFE904(カメラ拡張キット/4台)を別途購入していただく必要があります。

Broker Nodeが管理するFM Node台数：Broker Node 1台につき最大10台

    注) FM Nodeの台数には、Broker Nodeと同一PC内で動作するFM Nodeも含みます。

        よってマスターサーバー1台につきスレーブサーバーが最大9台となります。


推奨動作環境

CPU： | インテル® Xeon または Core i7シリーズ 3.40GHz 以上 （4コア8スレッド以上であること）
メモリー： | 16GB 以上
ハードディスク空き容量： | 1TB 以上
対応OS： | Microsoft® Windows® 7 Professional SP1（64bit）
 | Microsoft® Windows® 10 Professional RS1（64bit）
 | Microsoft® Windows Server® 2012 R2 Standard Edition SP1（64bit）

注) Windows7、Windows10をお使いの場合、定期的な再起動を推奨します。

Windows Server 2012をお使いの場合、.NET Framework 4.5.1のインストールが必要になります。


新規構築時の手順

新規構築時の手順は以下の通りです。

  注) マスターサーバーのみの場合は、マスターサーバー内のFM Nodeに、スレーブサーバーがある場合はマスター

      サーバー内のFM Nodeとスレーブサーバー内のFM Nodeに割当てるカメラをマスターサーバーに登録します。

スタートアップツールによる操作/設定(マスターサーバー)

スタートアップツールによる操作/設定(スレーブサーバー)

コンフィグツールによる操作/設定(マスターサーバー)

コンフィグツールによる操作/設定(スレーブサーバー)


スタートアップツールによる操作/設定(マスターサーバー)

マスターサーバーのCD-ROMドライブに付属のCD-ROMをセットします。

注)作業はすべて管理者権限を持つアカウントでログインした状態で行ってください。

スタートアップツールの起動

サーバータイプの選択

ソフトウェアのインストール

ライセンス登録

保存期間の設定


スタートアップツールの起動

スタートアップツールを起動します。

(1) CD-ROMにある「ASF900Launcher.exe」を実行します。

PCに.NET Framework 4.5.1がインストールされていない場合、自動で.NET Framework 4.5.1をインストールし、インストール後にセットアップツールのメイン画面を表示します。

既にPCに.NET Framework4.5.1がインストールされている場合、 .NET Framework 4.5.1のインストールはスキップされます。


サーバータイプの選択

(1) 「Select server type」で「Broker＋Face Matching(Master)」を選択します。

(2) IPアドレス入力欄からPCのIPアドレスを選択します。

(3) 「Next」をクリックします。

(3)

(2)

(1)


ソフトウェアのインストール

(1) 「サーバータイプの選択」で「Next」をクリックすると、自動で「Java Runtime」、「PostgreSQL」、「Visual C++ 2005 runtime」、「Visual C++ 2008 runtime」がインストールされ、続いて「WV-ASF900」の使用許諾契約書が表示されます。

(2) 「使用許諾契約書に同意します」にチェックをし、「インストール」をクリックします。

    注) 説明に使用している画面表示(バージョン表示など)は本ソフトウェアのバージョンにより異なります。

(3) 「完了」をクリックしてインストールを終了します。

    注) 説明に使用している画面表示(バージョン表示など)は本ソフトウェアのバージョンにより異なります。

(4) 自動で本ソフトウェアに必要なデータベースが作成されます。

(5) ソフトウェアのインストール完了と「Next」をクリックするメッセージが表示され、「Next」ボタンが表示されたことを確認し、「Next」をクリックします。


ライセンス登録

マスターサーバー内のFM Nodeにはネットワークカメラ4台のライセンスが含まれており、その解除キー番号を設定します。

FM Nodeに5台以上のネットワークカメラを接続する場合、別途購入のWV-ASFE901(カメラ拡張キット/1台)、WV-ASFE904(カメラ拡張キット/4台)の解除キー番号も設定します。

(1) MPR-ID(機器ID番号)を確認します。

MPR ID | 機器ID番号
Activation ID | 起動ID番号
Registration ID | 暗号ID番号
Registration Key | 解除キー番号

(2) キー管理システムで解除キー番号を発行しRegistration Key欄へ入力します。

続いて「Add」をクリックします。

カメラ拡張キットの解除キー番号も同様に入力します。

項目を変更したり削除したりする場合は、リストから対象のキーを選択して、それぞれ「Modify」「Delete」をクリックします。

(3) 「Register」をクリックします。

(4) ライセンスの「Status」が「Activated」となっていることを確認します。

注）登録後に登録の変更、削除はできません。

(5) 「Finish」をクリックします。

(3)

(1)

(5)

(4)

(2)

(6) PCのOSがWindows10の場合は「OK」をクリックし、Windows10以外の場合は「キャンセル」をクリックします。

「OK」をクリックするとPCは再起動します。

「キャンセル」をクリックするとPCは再起動せず、スタートアップツールが終了します。


保存期間の設定

顔画像や履歴の保存期間、タイムゾーンを設定します。

(1) エクスプローラーで「C:\ASF900\batch\conf\ext02\batchConfig.xml」をメモ帳などで開きます。

(2) 保存期間を設定します。

項目 | 設定キー名 | 初期値
顔画像保存日数 | faceMdDataRelatedInfoRetentionPeriod | 31日
顔画像保存件数 | faceMdDataRelatedInfoRetentionNumberr | 5,000,000件*
顔照合アラーム履歴保存日数 | rtAlarmHistoryRetentionPeriod | 31日
年齢性別統計保存日数 | ageAndSexStatisticalInfoRetentionPeriod | 186日
タイムゾーン | timeDifference | 9時間

    注）最大1000万件まで設定できます。500万件以上に設定すると検索に時間がかかり表示されない場合が

        ありますので、検索日時の範囲、カメラ台数を絞って検索してください。


スタートアップツールによる操作/設定(スレーブサーバー)

スレーブサーバーのCD-ROMドライブに付属のCD-ROMをセットします。

マスターサーバーのみでスレーブサーバーがないシステム構成の場合、トピック『コンフィグツールによる操作/設定(マスターサーバー)』へ移行してください。

注)作業はすべて管理者権限を持つアカウントでログインした状態で行ってください。

スタートアップツールの起動

サーバータイプの選択

ソフトウェアのインストール

ライセンス登録

保存期間の設定


サーバータイプの選択

(1) 「Select server type」で「Face Matching(Slave)」を選択します。

(2) IPアドレス入力欄からPCのIPアドレスを選択します。

(3) Broker NodeのIPアドレス入力欄にマスターサーバー(Broker Node)のIPアドレスを入力します。

(4) 「Next」をクリックします。

注) 「Next」をクリックした際にエラーが表示される場合、マスターサーバーでトピック『スタートアップツール

による操作/設定(マスターサーバー)』の作業を実施していない、またはスレーブサーバーとマスターサーバー

間の通信ができていない可能性があります。

原因を究明して対処した後に作業を再開してください。

(4)

(1)

(3)

(2)


ライセンス登録

スレーブサーバー内のFM Nodeにはネットワークカメラ4台のライセンスが含まれており、その解除キー番号を設定します。

FM Nodeに5台以上のネットワークカメラを接続する場合、別途購入のWV-ASFE901(カメラ拡張キット/1台)、WV-ASFE904(カメラ拡張キット/4台)の解除キー番号も設定します。

(1) MPR-ID(機器ID番号)を確認します。

MPR ID | 機器ID番号
Activation ID | 起動ID番号
Registration ID | 暗号ID番号
Registration Key | 解除キー番号

(2) キー管理システムで解除キー番号を発行しRegistration Keyの欄へ入力します。

続いて「Add」をクリックします。

カメラ拡張キットの解除キー番号も同様に入力します。

項目を変更したり削除したりする場合は、リストから対象のキーを選択して、それぞれ「Modify」「Delete」をクリックします。

(3) 「Register」をクリックします。

(4) ライセンスの「Status」が「Activated」となっていることを確認します。

注）登録後に登録の変更、削除はできません。

(5) 「Finish」をクリックします。

(5)

(3)

(4)

(2)

(1)

(6) PCのOSがWindows10の場合は「OK」をクリックし、Windows10以外の場合は「キャンセル」をクリックします。

「OK」をクリックするとPCは再起動します。

「キャンセル」をクリックするとPCは再起動せず、スタートアップツールが終了します。


コンフィグツールによる操作/設定(マスターサーバー)

マスターサーバーのCD-ROMドライブに付属のCD-ROMをセットします。

注)作業はすべて管理者権限を持つアカウントでログインした状態で行ってください。

コンフィグツールの起動

カメラ登録

クライアント端末登録

プロセス起動


コンフィグツールの起動

コンフィグツールを起動します。

(1) 「04_Tools」フォルダにある「ASF900ConfigTool.exe」を実行します。

コンフィグツールのメイン画面が表示されます。

コンフィグツールを起動すると、マスターサーバー内の設定情報を取込み、Broker NodeのIPアドレスが表示され

設定済みのシステム構成機器がツリー表示されます。

マスターサーバー内のFM Node

マスターサーバー内のBroker Node

スレーブサーバー内のFM Node

    ※注

    注) マスターサーバーのみのシステム構成の場合、スレーブサーバー内のFM Nodeは表示されません。

(2) PCのOSがWindows10の場合、以下の操作をします。

①「Process Control」タブをクリックします。

②「Stop」をクリックします

③全てのプロセスが「Stopped」と表示されることを確認します。

③

②

①


カメラ登録

マスターサーバーのみのシステム構成の場合はマスターサーバー内のFM Node、スレーブサーバーがあるシステム構成の場合はマスターサーバー内のFM Nodeとスレーブサーバー内のFM Nodeに割り付けるカメラを登録します。

(1) 以下のどちらかの操作をします。

①マスターサーバー内のFM Nodeを選択し、「Add a camera」をクリックします。

②マスターサーバー内のFM Nodeで右クリックし、「Add a camera」をクリックします。

(2) 割り当てるカメラのIPアドレスと、カメラの認証情報(ユーザー名、パスワード)を入力し、「Connect」をクリックします。

(3) クライアント端末の種別を選択し、GUIDを入力します。

GUID

カメラを識別するID

接続するクライアントソフトをSelect Typeで選択し、GUIDを設定します。

※クライアント端末がASM200シリーズの場合は変更不要

(4) 「Camera setting」の項目を入力します。

「Face Detection」は「On」、「Face Matching Node IPA」はFace Matching Node欄に表示のIPアドレスを入力し、「Sensitivity」と「Port No.」は必要に応じて変更します。

Face Detection | 顔検出機能のOn/Off
Sensitivity | 顔検出感度（初期値：Low）
Face Matching Node IPA | 顔画像の送り先(FM Node)のIPアドレス
Port No. | 顔画像の送り先のポート番号(初期値：80)

(5) 続けて別のカメラを登録する場合は「Add」、そうでない場合は「Add and close」をクリックします。

(3)

(4)

(5)

(2)

(6) マスターサーバー内のFM Nodeにカメラが登録されたことを確認します。

  ①システム構成機器のツリーに登録したカメラが表示されている。

  ②FM Nodeを選択し、FM Nodeのカメラリストに登録したカメラが表示されている。

(7) マスターサーバー内のFM Nodeに割り付ける別のカメラがある場合、またはスレーブサーバーがある場合、同様の手順で登録します。

(8) カメラの設定を確認する場合は、システム構成機器のツリーからカメラを選択します。


クライアント端末登録

本システムで動作させるクライアント端末を登録します。

(1) 以下のどちらかの操作をします。

①「Terminal」を選択し、「Add a terminal」をクリック

②「Terminal」で右クリックし、「Add a terminal」をクリック

(2) クライアント端末の設定を入力します。

MACアドレスは直接入力するか、MACアドレス参照機能を使用して入力します。

MACアドレス参照機能の使い方は本トピックの補足欄をご覧ください。

Terminal type | クライアント端末の種別とバージョン(初期値：ASM200 V3.2x)
Remarks | クライアント端末を識別するための備考欄
Terminal IP address | クライアント端末のIPアドレス
Port No. | クライアント端末のポート番号(初期値：1818)
MAC address | クライアント端末のMACアドレス

(3) 続けて別のクライアント端末を登録する場合は「Add」、そうでない場合は「Add and close」をクリックします。

(2)

(3)

(4) 本システムにクライアント端末が登録されたことを確認します。

      ①システム構成機器のツリーに登録したクライアント端末が表示されている。

      ②「Terminal」を選択し、クライアント端末リストに登録したクライアント端末が表示されている。

(5) 別のクライアント端末がある場合、同様の手順で登録します。

【補足】MACアドレス参照機能

(1) 参照ボタンをクリックします。

(2) クライアント端末のIPアドレスを入力し、「Search」をクリックします。

(3) MACアドレス欄にクライアント端末のMACアドレスが表示されたことを確認し、「OK」をクリックします。

(3)

(2)


プロセス起動

マスターサーバー内のBroker NodeおよびFM Nodeのプロセスを起動します。

(1) 「Process Control」タブを選択します。

(2) 「Start」をクリックします。

(3) 全てのプロセスが「Running」と表示されることを確認します。

(3)

(2)

(1)


コンフィグツールによる操作/設定(スレーブサーバー)

スレーブサーバーとするPCのCD-ROMドライブに付属のCD-ROMをセットします。

注)作業はすべて管理者権限を持つアカウントでログインした状態で行ってください。

コンフィグツールの起動

プロセス起動


コンフィグツールの起動

コンフィグツールを起動します。

(1) 「04_Tools」フォルダにある「ASF900ConfigTool.exe」を実行します。

コンフィグツールのメイン画面が表示されます。

コンフィグツールを起動すると、マスターサーバー内の設定情報を取込み、Broker NodeのIPアドレスが表示され

設定済みのシステム構成機器がツリー表示されます。

(2) PCのOSがWindows10の場合、以下の操作をします。

①「Process Control」タブをクリックします。

②「Stop」をクリックします

③全てのプロセスが「Stopped」と表示されることを確認します。

注)「ASF900BRK01」、「ASF900BRK03」、「ASF900BrokerManager」は「Not installed」と表示されます。

①

②

③


プロセス起動

スレーブサーバー内のFM Nodeのプロセスを起動します。

(1) 「Process Control」タブを選択します。

(2) 「Start」をクリックします。

(3) 全てのプロセスが「Running」と表示されることを確認します。

注)「ASF900BRK01」、「ASF900BRK03」、「ASF900BrokerManager」は「Not installed」と表示されます。

(3)

(2)

(1)


システム運用開始後の設定変更手順

システム運用開始後に生じることがある設定変更手順について説明します。

システム構成機器の追加

システム構成機器の削除


システム構成機器の追加

FM Node、カメラ、クライアント端末を追加する場合の手順を説明します。

FM Nodeの追加

カメラの追加

クライアント端末の追加


FM Nodeの追加

(1) トピック『新規構築時の手順』－『スタートアップツールによる操作/設定(スレーブサーバー)』を参照し、設定します。


カメラの追加

(1) 以下のPCのCD-ROMドライブに付属のCD-ROMをセットします。

・カメラを追加するFM Nodeがマスターサーバー内の場合：マスターサーバー

・カメラを追加するFM Nodeがスレーブサーバー内の場合：スレーブサーバー

(2) 「04_Tools」フォルダにある「ASF900ConfigTool.exe」を実行し、コンフィグツールを起動します。

(3) カメラの追加にあたりカメラ拡張キットのライセンスの登録が必要の場合、以下の操作をします。

カメラ拡張キットのライセンスの登録が不要の場合は手順(4)へ移行します。

①「License Management」タブをクリックします。

② キー管理システムで解除キー番号を発行しRegistration Key欄へ入力し、「Add」をクリックします。

③「Register」をクリックします。

④ ライセンスの「Status」が「Activated」になっていることを確認します。

      注) 「License Management」タブは、コンフィグツールを起動したPCに対する操作/設定となります。

          コンフィグツールを起動したPCから、別のPCに対してライセンスを登録することはできません。

          そのため手順(1)でカメラを追加するFM Nodeのサーバーでコンフィグツールを起動しています。

④

②

③

①

(4) 「Server Configuration」タブをクリックします。

(5) トピック『新規構築時の手順』－『コンフィグツールによる操作/設定(マスターサーバー)』または『コンフィグツールによる操作/設定(スレーブサーバー)』－『カメラ登録』を参照し、追加するカメラを登録します。

(6) 「Process Control」タブをクリックします。

    注)「Process Control」タブは、コンフィグツールを起動したPCに対する操作するものです。

        コンフィグツールを起動したPCとは異なるPCに対してプロセスの操作はできません。

(7) 「Stop」をクリックし、全てのプロセスが「Stopped」と表示されることを確認します。

    注) マスターサーバーのプロセス停止はシステム全体の運用に影響が与えますのでご注意ください。

    注) スレーブサーバーでは「ASF900BRK01」、「ASF900BRK03」、「ASF900BrokerManager」は「Not installed」

        のままとなります。

(7)

(6)

(8) 「Start」をクリックし、全てのプロセスが「Running」と表示されることを確認します。

  注) スレーブサーバーでは「ASF900BRK01」、「ASF900BRK03」、「ASF900BrokerManager」は「Not installed」

        のままとなります。

  注) カメラを追加するFM Nodeのプロセスを再起動することで登録したカメラが有効な状態となります。

      (カメラを追加するFM Nodeがスレーブサーバーの場合、マスターサーバーに対するプロセスの再起動は

必要ありません。)

プロセスの再起動を実施しないと、システム構成機器のツリーに登録したカメラが表示されますが、

有効な状態となっていませんのでご注意ください。

(8)


クライアント端末の追加

(1) マスターサーバーのCD-ROMドライブに付属のCD-ROMをセットします。

(2) 「04_Tools」フォルダにある「ASF900ConfigTool.exe」を実行し、コンフィグツールを起動します。

(3) トピック『新規構築時の手順』－『コンフィグツールによる操作/設定(マスターサーバー)』－『クライアント端末登録』を参照し、追加するクライアント端末を登録します。

(4) 「Process Control」タブをクリックします。

(5) 「Stop」をクリックし、全てのプロセスが「Stopped」と表示されることを確認します。

    注) マスターサーバーのプロセス停止はシステム全体の運用に影響が与えますのでご注意ください。

(5)

(4)

(6) 「Start」をクリックし、全てのプロセスが「Running」と表示されることを確認します。

(6)

(7) スレーブサーバーのCD-ROMドライブに付属のCD-ROMをセットします。

(8) 「04_Tools」フォルダにある「ASF900ConfigTool.exe」を実行し、コンフィグツールを起動します。

(9) 手順(4)～(6)を参照し、スレーブサーバー内のFM Nodeのプロセスを再起動します。

    注) スレーブサーバーでは「ASF900BRK01」、「ASF900BRK03」、「ASF900BrokerManager」は「Not installed」

        のままとなります。

注) マスターサーバーおよびスレーブサーバーのプロセスの再起動を実施により登録したカメラが有効な状態と

なります。

プロセスの再起動を実施しないと、システム構成機器のツリーに登録したクライアント端末が表示され

ますが、有効な状態となっていませんのでご注意ください。


システム構成機器の削除

FM Node、カメラ、クライアント端末を削除する場合の手順を説明します。

FM Nodeの削除

カメラの削除

クライアント端末の削除


FM Nodeの削除

(1) マスターサーバーまたはスレーブサーバーのCD-ROMドライブに付属のCD-ROMをセットします。

(2) 「04_Tools」フォルダにある「ASF900ConfigTool.exe」を実行し、コンフィグツールを起動します。

  注) コンフィグツールを起動するとマスターサーバー内のBroker Nodeの情報を取得し、システム機器構成

      のツリーを表示します。

          スレーブサーバー内にもBroker Nodeの基本情報があり、その情報を元にマスターサーバー内のBroker

Nodeへ情報の取得にいくため、同一のシステム機器構成のツリーが表示されます。

(3) 削除するFM Nodeを選択します。

(4) 「Delete」をクリックします。

(3)

(4)

(5) FM Node削除を確認するダイアログで「OK」をクリックします。

(5)


カメラの削除

(1) 以下のPCのCD-ROMドライブに付属のCD-ROMをセットします。

・カメラを削除するFM Nodeがマスターサーバー内の場合：マスターサーバー

・カメラを削除するFM Nodeがスレーブサーバー内の場合：スレーブサーバー

(2) 「04_Tools」フォルダにある「ASF900ConfigTool.exe」を実行し、コンフィグツールを起動します。

(3) 削除するカメラを選択します。

(4) 「Delete」をクリックします。

(3)

(4)

(5) カメラ削除を確認するダイアログで「OK」をクリックします。

(5)

(6) 「Process Control」タブをクリックします。

(7) 「Stop」をクリックし、全てのプロセスが「Stopped」と表示されることを確認します。

    注) マスターサーバーのプロセス停止はシステム全体の運用に影響が与えますのでご注意ください。

    注) スレーブサーバーでは「ASF900BRK01」、「ASF900BRK03」、「ASF900BrokerManager」は「Not installed」

        のままとなります。

(6)

(7)

(8) 「Start」をクリックし、全てのプロセスが「Running」と表示されることを確認します。

(8)

注) カメラを削除するFM Nodeのプロセスを再起動することでカメラの削除が反映されます。

    (カメラを削除するFM Nodeがスレーブサーバーの場合、マスターサーバーに対するプロセスの再起動は

必要ありません。)

プロセスの再起動を実施しないと、システム構成機器のツリーから削除したカメラが表示されなくなりますが、

削除が反映されていない状態ですのでご注意ください。


クライアント端末の削除

(1) マスターサーバーのCD-ROMドライブに付属のCD-ROMをセットします。

(2) 「04_Tools」フォルダにある「ASF900ConfigTool.exe」を実行し、コンフィグツールを起動します。

(3) 削除するクライアント端末を選択します。

(4) 「Delete」をクリックします。

(3)

(4)

(5) クライアント端末を確認するダイアログで「OK」をクリックします。

(5)

(6) 「Process Control」タブをクリックします。

(7) 「Stop」をクリックし、全てのプロセスが「Stopped」と表示されることを確認します。

    注) マスターサーバーのプロセス停止はシステム全体の運用に影響が与えますのでご注意ください。

(6)

(7)

(8) 「Start」をクリックし、全てのプロセスが「Running」と表示されることを確認します。

(8)

(9) スレーブサーバーのCD-ROMドライブに付属のCD-ROMをセットします。

(10) 「04_Tools」フォルダにある「ASF900ConfigTool.exe」を実行し、コンフィグツールを起動します。

(11) 手順(6)～(8)を参照し、スレーブサーバー内のFM Nodeのプロセスを再起動します。

    注) スレーブサーバーでは「ASF900BRK01」、「ASF900BRK03」、「ASF900BrokerManager」は「Not installed」

        のままとなります。

注) マスターサーバーおよびスレーブサーバーのプロセスの再起動を実施によりクライアント端末の削除が

反映されます。

プロセスの再起動を実施しないと、システム構成機器のツリーから削除したクライアント端末が表示されなく

なりますが、削除が反映されていない状態ですのでご注意ください。


トラブルシュート

事 象 | 原 因 と 対 応
ディスク容量が不足している。 | 本機に蓄積した顔のサムネイル画像および、顔の特徴情報のデータベースを保存する空き容量が少なくなっています。 →システム管理者または販売店へご相談ください。
ネットワークカメラからの顔画像が受信できない | 以下の原因が考えられます。 ① 本機のシステム設定の間違い →本機に設定したネットワークカメラのMACアドレスまたはIPアドレスを確認してください。 ② ネットワークカメラに拡張機能ソフトウェアがインストールされていない →ネットワークカメラに拡張機能ソフトウェアをインストールしてください。 ③ ネットワークカメラのシステム設定の間違い →ネットワークカメラの顔画像の送信設定を確認してください。 顔画像の受信状況をツールソフトで確認できます。 詳しくはシステム管理者または販売店へお問い合わせください。
顔検索の結果が表示されない。 | 「Process Control」のタブで、ASF900MSMのサービスが起動しているか確認してください。起動していない場合、本機のデータベースが破損している可能性があります。 破損しているデータベースをツールソフトで修復・初期化できます。詳しくはシステム管理者または販売店へお問い合わせください。
クライアント端末で、サーバー情報およびカメラ情報が取得できない。 | 以下の原因が考えられます。 ① クライアント端末のMACアドレスが登録されていない。 →Terminal Settingタブで、MACアドレスを登録してください。 ② Server ID、Node Noの設定が誤っている。 →Server Configurationタブで登録したServer ID、Node NoをSystem Settingタブで各PCに登録できているか確認してください。 ③ FM Nodeでカメラの設定が有効になっていない。 →「Process Control」のタブでサービスを再起動してください。


オープンソースソフトウェア

本ソフトウェアの一部はオープンソースソフトウェアを使用しています。関係する利用規約は、本ソフトウェアにも適用します。以下の著作権やライセンス情報に関するお問合せは当社ではお請けいたしかねます。

Apache

CodeIgniter

OpenCV

OpenSSL

PHP

PostgreSQL

Redis

PostgreSQL JDBC Driver


Apache

Apache License

Version 2.0, January 2004

http://www.apache.org/licenses/

TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION

1. Definitions.

"License" shall mean the terms and conditions for use, reproduction,

and distribution as defined by Sections 1 through 9 of this document.

"Licensor" shall mean the copyright owner or entity authorized by

the copyright owner that is granting the License.

"Legal Entity" shall mean the union of the acting entity and all

other entities that control, are controlled by, or are under common

control with that entity. For the purposes of this definition,

"control" means (i) the power, direct or indirect, to cause the

direction or management of such entity, whether by contract or

otherwise, or (ii) ownership of fifty percent (50%) or more of the

outstanding shares, or (iii) beneficial ownership of such entity.

"You" (or "Your") shall mean an individual or Legal Entity

exercising permissions granted by this License.

"Source" form shall mean the preferred form for making modifications,

including but not limited to software source code, documentation

source, and configuration files.

"Object" form shall mean any form resulting from mechanical

transformation or translation of a Source form, including but

not limited to compiled object code, generated documentation,

and conversions to other media types.

"Work" shall mean the work of authorship, whether in Source or

Object form, made available under the License, as indicated by a

copyright notice that is included in or attached to the work

(an example is provided in the Appendix below).

"Derivative Works" shall mean any work, whether in Source or Object

form, that is based on (or derived from) the Work and for which the

editorial revisions, annotations, elaborations, or other modifications

represent, as a whole, an original work of authorship. For the purposes

of this License, Derivative Works shall not include works that remain

separable from, or merely link (or bind by name) to the interfaces of,

the Work and Derivative Works thereof.

"Contribution" shall mean any work of authorship, including

the original version of the Work and any modifications or additions

to that Work or Derivative Works thereof, that is intentionally

submitted to Licensor for inclusion in the Work by the copyright owner

or by an individual or Legal Entity authorized to submit on behalf of

the copyright owner. For the purposes of this definition, "submitted"

means any form of electronic, verbal, or written communication sent

to the Licensor or its representatives, including but not limited to

communication on electronic mailing lists, source code control systems,

and issue tracking systems that are managed by, or on behalf of, the

Licensor for the purpose of discussing and improving the Work, but

excluding communication that is conspicuously marked or otherwise

designated in writing by the copyright owner as "Not a Contribution."

"Contributor" shall mean Licensor and any individual or Legal Entity

on behalf of whom a Contribution has been received by Licensor and

subsequently incorporated within the Work.

2. Grant of Copyright License. Subject to the terms and conditions of

this License, each Contributor hereby grants to You a perpetual,

worldwide, non-exclusive, no-charge, royalty-free, irrevocable

copyright license to reproduce, prepare Derivative Works of,

publicly display, publicly perform, sublicense, and distribute the

Work and such Derivative Works in Source or Object form.

` 3. Grant of Patent License. Subject to the terms and conditions of

this License, each Contributor hereby grants to You a perpetual,

worldwide, non-exclusive, no-charge, royalty-free, irrevocable

(except as stated in this section) patent license to make, have made,

use, offer to sell, sell, import, and otherwise transfer the Work,

where such license applies only to those patent claims licensable

by such Contributor that are necessarily infringed by their

Contribution(s) alone or by combination of their Contribution(s)

with the Work to which such Contribution(s) was submitted. If You

institute patent litigation against any entity (including a

cross-claim or counterclaim in a lawsuit) alleging that the Work

or a Contribution incorporated within the Work constitutes direct

or contributory patent infringement, then any patent licenses

granted to You under this License for that Work shall terminate

as of the date such litigation is filed.

4. Redistribution. You may reproduce and distribute copies of the

Work or Derivative Works thereof in any medium, with or without

modifications, and in Source or Object form, provided that You

meet the following conditions:

(a) You must give any other recipients of the Work or

Derivative Works a copy of this License; and

(b) You must cause any modified files to carry prominent notices

stating that You changed the files; and

(c) You must retain, in the Source form of any Derivative Works

that You distribute, all copyright, patent, trademark, and

attribution notices from the Source form of the Work,

excluding those notices that do not pertain to any part of

the Derivative Works; and

(d) If the Work includes a "NOTICE" text file as part of its

distribution, then any Derivative Works that You distribute must

include a readable copy of the attribution notices contained

within such NOTICE file, excluding those notices that do not

pertain to any part of the Derivative Works, in at least one

of the following places: within a NOTICE text file distributed

as part of the Derivative Works; within the Source form or

documentation, if provided along with the Derivative Works; or,

within a display generated by the Derivative Works, if and

wherever such third-party notices normally appear. The contents

of the NOTICE file are for informational purposes only and

do not modify the License. You may add Your own attribution

notices within Derivative Works that You distribute, alongside

or as an addendum to the NOTICE text from the Work, provided

that such additional attribution notices cannot be construed

as modifying the License.

You may add Your own copyright statement to Your modifications and

may provide additional or different license terms and conditions

for use, reproduction, or distribution of Your modifications, or

for any such Derivative Works as a whole, provided Your use,

reproduction, and distribution of the Work otherwise complies with

the conditions stated in this License.

5. Submission of Contributions. Unless You explicitly state otherwise,

any Contribution intentionally submitted for inclusion in the Work

by You to the Licensor shall be under the terms and conditions of

this License, without any additional terms or conditions.

Notwithstanding the above, nothing herein shall supersede or modify

the terms of any separate license agreement you may have executed

with Licensor regarding such Contributions.

6. Trademarks. This License does not grant permission to use the trade

names, trademarks, service marks, or product names of the Licensor,

except as required for reasonable and customary use in describing the

origin of the Work and reproducing the content of the NOTICE file.

7. Disclaimer of Warranty. Unless required by applicable law or

agreed to in writing, Licensor provides the Work (and each

Contributor provides its Contributions) on an "AS IS" BASIS,

WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or

implied, including, without limitation, any warranties or conditions

of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A

PARTICULAR PURPOSE. You are solely responsible for determining the

appropriateness of using or redistributing the Work and assume any

risks associated with Your exercise of permissions under this License.

8. Limitation of Liability. In no event and under no legal theory,

whether in tort (including negligence), contract, or otherwise,

unless required by applicable law (such as deliberate and grossly

negligent acts) or agreed to in writing, shall any Contributor be

liable to You for damages, including any direct, indirect, special,

incidental, or consequential damages of any character arising as a

result of this License or out of the use or inability to use the

Work (including but not limited to damages for loss of goodwill,

work stoppage, computer failure or malfunction, or any and all

other commercial damages or losses), even if such Contributor

has been advised of the possibility of such damages.

9. Accepting Warranty or Additional Liability. While redistributing

the Work or Derivative Works thereof, You may choose to offer,

and charge a fee for, acceptance of support, warranty, indemnity,

or other liability obligations and/or rights consistent with this

License. However, in accepting such obligations, You may act only

on Your own behalf and on Your sole responsibility, not on behalf

of any other Contributor, and only if You agree to indemnify,

defend, and hold each Contributor harmless for any liability

incurred by, or claims asserted against, such Contributor by reason

of your accepting any such warranty or additional liability.

END OF TERMS AND CONDITIONS

APPENDIX: How to apply the Apache License to your work.

To apply the Apache License to your work, attach the following

boilerplate notice, with the fields enclosed by brackets "[]"

replaced with your own identifying information. (Don't include

the brackets!) The text should be enclosed in the appropriate

comment syntax for the file format. We also recommend that a

file or class name and description of purpose be included on the

same "printed page" as the copyright notice for easier

identification within third-party archives.

Copyright [yyyy] [name of copyright owner]

Licensed under the Apache License, Version 2.0 (the "License");

you may not use this file except in compliance with the License.

You may obtain a copy of the License at

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software

distributed under the License is distributed on an "AS IS" BASIS,

WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.

See the License for the specific language governing permissions and

limitations under the License.

=========================================================================

== Example NOTICE file for use with the Apache License, Version 2.0, ==

== in this case for the Apache httpd-2.0 distribution. ==

=========================================================================

Apache HTTP Server

Copyright 1999-2006 The Apache Software Foundation

This product includes software developed at

The Apache Software Foundation (http://www.apache.org/).

Portions of this software were developed at the National Center

for Supercomputing Applications (NCSA) at the University of

Illinois at Urbana-Champaign.

This software contains code derived from the RSA Data Security

Inc. MD5 Message-Digest Algorithm, including various

modifications by Spyglass Inc., Carnegie Mellon University, and

Bell Communications Research, Inc (Bellcore).

Regular expression support is provided by the PCRE library package,

which is open source software, written by Philip Hazel, and copyright

by the University of Cambridge, England. The original software is

available from

ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/


CodeIgniter

CodeIgniter License Agreement

Copyright (c) 2008 - 2014, EllisLab, Inc.

All rights reserved.

This license is a legal agreement between you and EllisLab Inc. for the use of CodeIgniter Software (the "Software"). By obtaining the Software you agree to comply with the terms and conditions of this license.

Permitted Use

You are permitted to use, copy, modify, and distribute the Software and its documentation, with or without modification, for any purpose, provided that the following conditions are met:

1.A copy of this license agreement must be included with the distribution.

2.Redistributions of source code must retain the above copyright notice in all source code files.

3.Redistributions in binary form must reproduce the above copyright notice in the documentation and/or other materials provided with the distribution.

4.Any files that have been modified must carry notices stating the nature of the change and the names of those who changed them.

5.Products derived from the Software must include an acknowledgment that they are derived from CodeIgniter in their documentation and/or other materials provided with the distribution.

6.Products derived from the Software may not be called "CodeIgniter", nor may "CodeIgniter" appear in their name, without prior written permission from EllisLab, Inc.

Indemnity

You agree to indemnify and hold harmless the authors of the Software and any contributors for any direct, indirect, incidental, or consequential third-party claims, actions or suits, as well as any related expenses, liabilities, damages, settlements or fees arising from your use or misuse of the Software, or a violation of any terms of this license.

Disclaimer of Warranty

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, WARRANTIES OF QUALITY, PERFORMANCE, NON-INFRINGEMENT, MERCHANTABILITY, OR FITNESS FOR A PARTICULAR PURPOSE.

Limitations of Liability

YOU ASSUME ALL RISK ASSOCIATED WITH THE INSTALLATION AND USE OF THE SOFTWARE. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS OF THE SOFTWARE BE LIABLE FOR CLAIMS, DAMAGES OR OTHER LIABILITY ARISING FROM, OUT OF, OR IN CONNECTION WITH THE SOFTWARE. LICENSE HOLDERS ARE SOLELY RESPONSIBLE FOR DETERMINING THE APPROPRIATENESS OF USE AND ASSUME ALL RISKS ASSOCIATED WITH ITS USE, INCLUDING BUT NOT LIMITED TO THE RISKS OF PROGRAM ERRORS, DAMAGE TO EQUIPMENT, LOSS OF DATA OR SOFTWARE PROGRAMS, OR UNAVAILABILITY OR INTERRUPTION OF OPERATIONS.


OpenCV

By downloading, copying, installing or using the software you agree to this license.

If you do not agree to this license, do not download, install, copy or use the software.

License Agreement

For Open Source Computer Vision Library

(3-clause BSD License)

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

•Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

•Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

•Neither the names of the copyright holders nor the names of the contributors may be used to endorse or promote products derived from this software without specific prior written permission.

This software is provided by the copyright holders and contributors “as is” and any express or implied warranties, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose are disclaimed. In no event shall copyright holders or contributors be liable for any direct, indirect, incidental, special, exemplary, or consequential damages (including, but not limited to, procurement of substitute goods or services; loss of use, data, or profits; or business interruption) however caused and on any theory of liability, whether in contract, strict liability, or tort (including negligence or otherwise) arising in any way out of the use of this software, even if advised of the possibility of such damage.


OpenSSL

This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/)."

LICENSE ISSUES

==============

The OpenSSL toolkit stays under a dual license, i.e. both the conditions of

the OpenSSL License and the original SSLeay license apply to the toolkit.

See below for the actual license texts. Actually both licenses are BSD-style

Open Source licenses. In case of any license issues related to OpenSSL

please contact openssl-core@openssl.org.

OpenSSL License

---------------

/* ====================================================================

* Copyright (c) 1998-2011 The OpenSSL Project. All rights reserved.

*

* Redistribution and use in source and binary forms, with or without

* modification, are permitted provided that the following conditions

* are met:

*

* 1. Redistributions of source code must retain the above copyright

* notice, this list of conditions and the following disclaimer.

*

* 2. Redistributions in binary form must reproduce the above copyright

* notice, this list of conditions and the following disclaimer in

* the documentation and/or other materials provided with the

* distribution.

*

* 3. All advertising materials mentioning features or use of this

* software must display the following acknowledgment:

* "This product includes software developed by the OpenSSL Project

* for use in the OpenSSL Toolkit. (http://www.openssl.org/)"

*

* 4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to

* endorse or promote products derived from this software without

* prior written permission. For written permission, please contact

* openssl-core@openssl.org.

*

* 5. Products derived from this software may not be called "OpenSSL"

* nor may "OpenSSL" appear in their names without prior written

* permission of the OpenSSL Project.

*

* 6. Redistributions of any form whatsoever must retain the following

* acknowledgment:

* "This product includes software developed by the OpenSSL Project

* for use in the OpenSSL Toolkit (http://www.openssl.org/)"

*

* THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY

* EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE

* IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR

* PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR

* ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,

* SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT

* NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;

* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)

* HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,

* STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)

* ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED

* OF THE POSSIBILITY OF SUCH DAMAGE.

* ====================================================================

*

* This product includes cryptographic software written by Eric Young

* (eay@cryptsoft.com). This product includes software written by Tim

* Hudson (tjh@cryptsoft.com).

*

*/

Original SSLeay License

-----------------------

/* Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com)

* All rights reserved.

*

* This package is an SSL implementation written

* by Eric Young (eay@cryptsoft.com).

* The implementation was written so as to conform with Netscapes SSL.

*

* This library is free for commercial and non-commercial use as long as

* the following conditions are aheared to. The following conditions

* apply to all code found in this distribution, be it the RC4, RSA,

* lhash, DES, etc., code; not just the SSL code. The SSL documentation

* included with this distribution is covered by the same copyright terms

* except that the holder is Tim Hudson (tjh@cryptsoft.com).

*

* Copyright remains Eric Young's, and as such any Copyright notices in

* the code are not to be removed.

* If this package is used in a product, Eric Young should be given attribution

* as the author of the parts of the library used.

* This can be in the form of a textual message at program startup or

* in documentation (online or textual) provided with the package.

*

* Redistribution and use in source and binary forms, with or without

* modification, are permitted provided that the following conditions

* are met:

* 1. Redistributions of source code must retain the copyright

* notice, this list of conditions and the following disclaimer.

* 2. Redistributions in binary form must reproduce the above copyright

* notice, this list of conditions and the following disclaimer in the

* documentation and/or other materials provided with the distribution.

* 3. All advertising materials mentioning features or use of this software

* must display the following acknowledgement:

* "This product includes cryptographic software written by

* Eric Young (eay@cryptsoft.com)"

* The word 'cryptographic' can be left out if the rouines from the library

* being used are not cryptographic related :-).

* 4. If you include any Windows specific code (or a derivative thereof) from

* the apps directory (application code) you must include an acknowledgement:

* "This product includes software written by Tim Hudson (tjh@cryptsoft.com)"

*

* THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND

* ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE

* IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE

* ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE

* FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL

* DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS

* OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)

* HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT

* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY

* OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF

* SUCH DAMAGE.

*

* The licence and distribution terms for any publically available version or

* derivative of this code cannot be changed. i.e. this code cannot simply be

* copied and put under another distribution licence

* [including the GNU Public Licence.]

*/


PHP

This product includes PHP, freely available from <http://www.php.net/>.

This product includes PHP software, freely available from http://www.php.net/software/.

--------------------------------------------------------------------

The PHP License, version 3.01

Copyright (c) 1999 - 2014 The PHP Group. All rights reserved.

--------------------------------------------------------------------

Redistribution and use in source and binary forms, with or without

modification, is permitted provided that the following conditions

are met:

1. Redistributions of source code must retain the above copyright

notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright

notice, this list of conditions and the following disclaimer in

the documentation and/or other materials provided with the

distribution.

3. The name "PHP" must not be used to endorse or promote products

derived from this software without prior written permission. For

written permission, please contact group@php.net.

4. Products derived from this software may not be called "PHP", nor

may "PHP" appear in their name, without prior written permission

from group@php.net. You may indicate that your software works in

conjunction with PHP by saying "Foo for PHP" instead of calling

it "PHP Foo" or "phpfoo"

5. The PHP Group may publish revised and/or new versions of the

license from time to time. Each version will be given a

distinguishing version number.

Once covered code has been published under a particular version

of the license, you may always continue to use it under the terms

of that version. You may also choose to use such covered code

under the terms of any subsequent version of the license

published by the PHP Group. No one other than the PHP Group has

the right to modify the terms applicable to covered code created

under this License.

6. Redistributions of any form whatsoever must retain the following

acknowledgment:

"This product includes PHP software, freely available from

<http://www.php.net/software/>".

THIS SOFTWARE IS PROVIDED BY THE PHP DEVELOPMENT TEAM ``AS IS'' AND

ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,

THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A

PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE PHP

DEVELOPMENT TEAM OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT,

INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES

(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR

SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)

HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,

STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)

ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED

OF THE POSSIBILITY OF SUCH DAMAGE.

--------------------------------------------------------------------

This software consists of voluntary contributions made by many

individuals on behalf of the PHP Group.

The PHP Group can be contacted via Email at group@php.net.

For more information on the PHP Group and the PHP project,

please see <http://www.php.net>.

PHP includes the Zend Engine, freely available at

<http://www.zend.com>.


PostgreSQL

PostgreSQL is released under the PostgreSQL License, a liberal Open Source license, similar to the BSD or MIT licenses.

PostgreSQL Database Management System

(formerly known as Postgres, then as Postgres95)

Portions Copyright (c) 1996-2015, The PostgreSQL Global Development Group

Portions Copyright (c) 1994, The Regents of the University of California

Permission to use, copy, modify, and distribute this software and its documentation for any purpose, without fee, and without a written agreement is hereby granted, provided that the above copyright notice and this paragraph and the following two paragraphs appear in all copies.

IN NO EVENT SHALL THE UNIVERSITY OF CALIFORNIA BE LIABLE TO ANY PARTY FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES, INCLUDING LOST PROFITS, ARISING OUT OF THE USE OF THIS SOFTWARE AND ITS DOCUMENTATION, EVEN IF THE UNIVERSITY OF CALIFORNIA HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

THE UNIVERSITY OF CALIFORNIA SPECIFICALLY DISCLAIMS ANY WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE SOFTWARE PROVIDED HEREUNDER IS ON AN "AS IS" BASIS, AND THE UNIVERSITY OF CALIFORNIA HAS NO OBLIGATIONS TO PROVIDE MAINTENANCE, SUPPORT, UPDATES, ENHANCEMENTS, OR MODIFICATIONS.


Redis

Redis license and trademark information

Redis is open source software released under the terms of the three clause BSD license. Most of the Redis source code was written and is copyrighted by Salvatore Sanfilippo and Pieter Noordhuis. A list of other contributors can be found in the git history.

The Redis trademark and logo are owned by Salvatore Sanfilippo and can be used in accordance with the Redis Trademark Guidelines.

*Three clause BSD license

Every file in the Redis distribution, with the exceptions of third party files specified in the list below, contain the following license:

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

-Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

-Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

-Neither the name of Redis nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

*Third party files and licenses

Redis uses source code from third parties. All this code contains a BSD or BSD-compatible license. The following is a list of third party files and information about their copyright.

-Redis uses the LHF compression library. LibLZF is copyright Marc Alexander Lehmann and is released under the terms of the two clause BSD license.

-Redis uses the sha1.c file that is copyright by Steve Reid and released under the public domain. This file is extremely popular and used among open source and proprietary code.

-When compiled on Linux Redis uses the Jemalloc allocator, that is copyright by Jason Evans, Mozilla Foundation and Facebook, Inc and is released under the two clause BSD license.

-Inside Jemalloc the file pprof is copyright Google Inc and released under the three clause BSD license.

-Inside Jemalloc the files inttypes.h, stdbool.h, stdint.h, strings.h under the msvc_compat directory are copyright Alexander Chemeris and released under the three clause BSD license.

-The libraries hiredis and linenoise also included inside the Redis distribution are copyright Salvatore Sanfilippo and Pieter Noordhuis and released under the terms respectively of the three clause BSD license and two clause BSD license.


PostgreSQL JDBC Driver

The PostgreSQL JDBC driver is distributed under the BSD license, same as the server. The simplest explanation of the licensing terms is that you can do whatever you want with the product and source code as long as you don't claim you wrote it or sue us. You should give it a read though, it's only half a page.

--------------------------------------------------------------------------------

Copyright (c) 1997-2011, PostgreSQL Global Development Group

All rights reserved.

Redistribution and use in source and binary forms, with or without

modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of the PostgreSQL Global Development Group nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.