WV-ASF950

顔認証サーバーソフトウェア WV-ASF950

・ このファイルをよくお読みの上、正しくお使いください。お読みになったあとは大切に保管し、必要なときにお読みください。

・ このファイルは管理者による管理をお勧めします。一般の利用者に開示するとセキュリティが損なわれる可能性があります。

【重要】予期しない電源断によるWindowsのシステムダウン時には、データベースの破損により顔検索、顔照合などの機能が動作しなくなる場合があります。UPS（無停電電源装置）などの利用を推奨します。

概要

はじめてお使いになる前に

新規構築時の手順

スケジュールによる再起動の設定(マスター/スレーブサーバー)

シャットダウンの監視 (マスター/スレーブサーバー)

システム運用開始後の設定変更手順

トラブルシュート

オープンソースソフトウェア


概要

顔認証サーバーソフトウェアWV-ASF950（以下、本ソフトウェア）はMicrosoft Windows上で動作する監視システム用途の顔認証ソフトウェアです。本ソフトウェアをインストールしたコンピューター（以下、PC）はパナソニック製の指定ネットワークカメラ（以下、カメラ）にて撮影された人物の顔画像を受信し、顔画像および顔の特徴情報をデータベースに蓄積します。登録済みの人物と照合された場合のアラーム通知や、本ソフトウェアに対応したクライアント端末からの操作により特定の人物を検出することができます。

本ソフトウェアにはカメラ4台のライセンスが含まれております。5台以上のカメラを接続する場合には別売りのカメラ拡張キットのライセンスを登録してください。また、アラーム対象の顔登録については、10000件のライセンスが含まれております。最大30000件まで登録数を増やす場合には、別売りの顔登録拡張キットのライセンスを登録してください。

対応カメラについては、付属のDVD-ROM内のreadme.txtをお読みください。

商標および登録商標について

用語について

著作権について

免責について

ネットワークに関するお願い

個人情報の保護について

注意事項


商標および登録商標について

・ Microsoft、Windowsは米国Microsoft Corporation の米国およびその他の国における登録商標です。

・ Intel、Intel Core、Xeonは、アメリカ合衆国および/またはその他の国におけるIntel Corporation またはその子会社の商標です。

・ AdobeおよびAdobeロゴ、およびReaderは、Adobe Systems Incorporated（アドビシステムズ社）の商標です。

・ NVIDIA、NVIDIAのロゴは、米国およびその他の国におけるNVIDIA Corporation の商標または登録商標です。

・ その他、本文中の社名や商品名は、各社の登録商標または商標です。


用語について

本書では、以下の用語を用いて説明しています。

登録した人物がカメラで検出された場合にアラームを発報する運用モードのことです。ASF950 Ver1.0以前でのご使用者は登録顔検知モードでの使用となります。

登録した人物がカメラで検出された場合にアラームを発報する動作と、登録していない人物がカメラで検出された場合にアラームを発報する動作を、エリア毎に選択できる運用モードのことです。


著作権について

本製品に含まれるソフトウェアの譲渡、コピー、逆アセンブル、逆コンパイル、リバースエンジニアリングは禁じられています。また本製品に含まれるすべてのソフトウェアの輸出法令に違反した輸出行為は禁じられています。


免責について

本製品は、ネットワークカメラで撮影された顔画像から、顔の特徴情報およびサムネイル画像をデータベースに蓄積し、本製品に対応したクライアント端末またはシステムからの操作により特定の顔の検索／照合、および統計情報を表示する目的で作られています、本製品単独で犯罪などを防止するものではありません。

弊社は、いかなる場合も以下に関して一切の責任を負わないものとします。

① 本製品に関連して直接または間接に発生した、偶発的、特殊、または結果的損害・被害

② お客様の誤使用や不注意による障害または本商品の破損など不便・損害・被害

③ お客様による本商品の逆コンパイル、逆アセンブルが行われた場合、それに起因するかどうかにかかわらず、発生した一切の故障または不具合

④ PCに保存された画像データ、音声データ、設定データの消失あるいは漏えいなどによるいかなる損害、クレームなど

⑤ ネットワーク上からの不正アクセスなど悪意を持った第三者による画像データ、音声データ、認証情報（ユーザー名、パスワード）の漏えいなどによるいかなる損害、クレームなど

⑥ お客様による監視画像・記録が何らかの理由（ユーザー認証OFFでの使用を含む）により公となり、使用され、
その結果生じた、被写体となった個人・団体などによるプライバシー侵害などを理由とする賠償請求、クレームなど

⑦ 登録した情報内容が何らかの原因（ユーザー名、パスワードなどの認証情報を忘れたことにより本商品を初期化する場合を含む）により、消失してしまうこと


ネットワークに関するお願い

本商品はネットワークへ接続して使用するため、以下のような被害を受けることが考えられます。

① 本商品を経由した情報の漏えいや流出

② 悪意を持った第三者による本商品の不正操作

③ 悪意を持った第三者による本商品の妨害や停止

このような被害を防ぐため、お客様の責任の下、下記のような対策も含め、ネットワークセキュリティ対策を十分に行ってください。

・ ファイアウォールなどを使用し、安全性の確保されたネットワーク上で本商品を使用する。

・ コンピューターが接続されているシステムで本商品を使用する場合、コンピューターウイルスや不正プログラムの感染に対するチェックや駆除が定期的に行われていることを確認する。

・ 不正な攻撃から守るため、ユーザー認証を利用し、ユーザー名とパスワードを設定し、ログインできるユーザーを制限する。

・ 管理者で本商品にアクセスしたあとは、必ずすべてのウェブブラウザーを閉じる。

・ 管理者のパスワードは、定期的に変更する。また、認証情報（ユーザー名、パスワード）を第三者の目に触れないよう、適切に保管する。

・ 画像データ、認証情報（ユーザー名、パスワード）アラームメール、FTPサーバー情報などをネットワーク上に漏えいさせないため、それらの情報を格納しているサーバーや各種接続機器に対してユーザー認証でアクセスを制限するなどの対策を実施する。


個人情報の保護について

本機を使用したシステムで撮影された本人が判別できる情報は、「個人情報の保護に関する法律」で定められた「個人情報」に該当します。

法律に従って、映像情報を適正にお取り扱いください。

※ 個人情報保護委員会の「個人情報の保護に関する法律についてのガイドライン」における【個人情報に該当する事例】を参照してください。


注意事項

・ カメラ、レコーダー、クライアントソフトウェア、I/O装置、Windows、データベースなどの認証情報は、第三者への漏洩がないように、管理者が適切に管理してください。

・ カメラ、レコーダー、クライアントソフトウェアなどのパスワードは、初期値から必ず変更し、適切な管理をおこなってください。

・ I/O装置は、装置の設定機能を使い、IPによるアクセス制限の設定、およびパスワードを初期値から変更することを必ず行ってください。

・ パスワードを入力する際は、背後からののぞき込みなどに注意してください。

・ 認証情報は、各ユーザーごとに設定し、共用しないようにしてください。

・ ユーザーのアクセス権限は、適切なものを設定してください。

・ ログインしたまま放置することで第三者から意図しない操作をされないように、オートログアウト機能などを用いて適切なログイン管理をするようにしてください。

・ アプリケーションをダウンロードする際は、公式のサイトからダウンロードをするようにしてください。

・ 出力機能を用いて出力したデータは、第三者への漏洩がないように、管理者が適切に管理してください。

・ PCを修理、廃棄、譲渡する場合は、HDDなどに情報が残っている場合がありますので、HDDを物理的に破壊するなど、適切な方法での管理をしてください。また、外部メディアを用いている場合は、事前に取り出し、第三者への漏洩がないように管理してください。

・ 認証情報が不明の場合は、初期化の必要があります。認証情報は、管理権限のある人だけが閲覧できる場所などに、適切に保管してください。

・ システムの設定データは、定期的にバックアップをとり管理しておくことを推奨します。

・ カメラ、レコーダー、PCなど、システム内の機器はNTPサーバーなどを用いて時刻を合わせるようにしてください。

・ お客様が準備したサーバー証明書については、お客様ご自身での有効期限の適切な管理をお願いします。

・ Windowsは、最新のセキュリティパッチを適用するようにしてください。また、環境に応じて適切なWindowsの設定をお願いします。

・ 本システムでは、HTTPSによる通信、および暗号化機能はデフォルトオフになっています。お客様の環境に応じて設定を有効にしてお使いください。


はじめてお使いになる前に

機能概要

システム機器構成

システム仕様

推奨動作環境


機能概要

本ソフトウェアは、本ソフトウェアに対応したクライアント端末またはシステムでの操作により各機能を利用します。

主な機能は以下の通りです。

① リアルタイム顔照合アラーム機能・・・本ソフトウェアに事前に登録した顔画像と類似した人物をネットワークカメラが捉えるとアラームを通知します。また、登録顔/未登録顔検知モードでは、登録していない人物をネットワークカメラが捉えた場合にアラームを通知することもできます。

② 顔検索機能・・・本ソフトウェアに蓄積した顔画像データから指示した顔画像と類似した顔画像を検索し、表示します。

③ 統計情報表示・・・指示した期間で性別、年代で区分した人数を表示します。

具体的な操作については本ソフトウェアに対応したクライアント端末またはシステムの取扱説明書を参照してください。


システム機器構成

本システムは管理機能を持つブローカーノード（Broker Node）と、映像を受信し顔照合を行うフェイスマッチングノード（Face Matching Node、FM Nodeと略します）で構成されます。

Broker Nodeとして動作するPCはFM Nodeとしても動作させ、そのPCをマスターサーバーと呼び、FM Nodeとしてのみ動作するPCをスレーブサーバーと呼びます。

注）上記のシステム機器構成は一例であり、使い方によりシステム構成は異なります。


システム仕様

接続可能なネットワークカメラ台数： FM Node 1台につき最大20台

注) WV-ASF950にはネットワークカメラ 4台のライセンスしか含まれておりません。
5台以上のネットワークカメラを接続する場合、WV-ASFE901W(カメラ拡張キット/1台)、WV-ASFE904W(カメラ拡張キット/4台)を別途購入していただく必要があります。

接続可能なネットワークカメラ台数： FM Node 1台につき最大10台

注) WV-ASF950にはネットワークカメラ 4台のライセンスしか含まれておりません。
5台以上のネットワークカメラを接続する場合、WV-ASFE901W(カメラ拡張キット/1台)、WV-ASFE904W(カメラ拡張キット/4台)を別途購入していただく必要があります。

Broker Nodeが管理するFM Node台数：Broker Node 1台につき最大10台

注) FM Nodeの台数には、Broker Nodeと同一PC内で動作するFM Nodeも含みます。
よってマスターサーバー1台につきスレーブサーバーが最大9台となります。

Broker Nodeが管理するI/O装置台数：Broker Node 1台につき最大10台

登録できるアラーム対象の顔登録数：最大30000件

注) WV-ASF950には、10000件のライセンスが含まれています。
10000件以上を登録する場合、WV-ASFE951W（顔登録拡張キット/10000件）を別途購入していただく必要があります。


推奨動作環境

OS | Microsoft Windows 10 Professional RS5 64ビット日本語版
 | Microsoft Windows Server 2016/2019 Standard Edition 日本語版 Microsoft Windows Server 2019 Standard Edition 日本語版
CPU | Intel® Xeon® または Intel® CoreTM i7シリーズ 3.40GHz 以上 （4コア8スレッド以上であること）
メモリー | 32GB 以上
GPUボード | NVIDIA® Quadro® P5000
DVD-ROMドライブ | 本ソフトウェアのインストール時に必要
ハードディスク容量 | 1TB 以上 ※1
画面 | 1280x800ピクセル以上の解像度、True color 24ビット以上
インターフェース | 100/1000 Mbpsのネットワークインターフェースカードが内蔵されていること ※2

※1） 本ソフトウェアのインストールとは別に、カメラやクライアント端末から受信した画像の保存先、
データベースの保存先として使用するためのハードディスク容量を用意する必要があります。

※2） PCのネットワーク設定は、お客様のネットワーク環境にあわせて設定していただく必要があります。
また、複数のネットワークインターフェースカードを用いて本ソフトウェアを使用した場合の動作は保証
いたしません。

Windows 10をお使いの場合、定期的な再起動を推奨します。
Windows Server 2016/2019をお使いの場合、.NET Framework 4.5.xのインストールが必要な場合があります。


新規構築時の手順

新規構築時の手順は以下の通りです。

注) マスターサーバーのみの場合は、マスターサーバー内のFM Nodeに、スレーブサーバーがある場合はマスターサーバー内のFM Nodeとスレーブサーバー内のFM Nodeに割当てるカメラをマスターサーバーに登録します。

スタートアップツールによる操作/設定(マスターサーバー)

スタートアップツールによる操作/設定(スレーブサーバー)

コンフィグツールによる操作/設定(マスターサーバー)

コンフィグツールによる操作/設定(スレーブサーバー)


スタートアップツールによる操作/設定(マスターサーバー)

マスターサーバーのDVD-ROMドライブに付属のDVD-ROMをセットします。

注)　作業はすべて管理者権限を持つアカウントでログインした状態で行ってください。

スタートアップツールの起動

データベースのパスワード設定

サーバータイプの選択

ソフトウェアのインストール

サーバー設定

セキュア設定

ライセンス登録


スタートアップツールの起動

スタートアップツールを起動します。

(1) DVD-ROMにある「ASF950Launcher.exe」を実行します。

PCに.NET Framework 4.5.xがインストールされていない場合、自動で.NET Framework 4.5.xをインストールし、インストール後にセットアップツールのメイン画面を表示します。

既にPCに.NET Framework4.5.xがインストールされている場合、 .NET Framework 4.5.xのインストールはスキップされます。


データベースのパスワード設定

(1) パスワード入力欄にパスワードを入力します。

・英字(大文字)、英字(小文字)、数字、記号のうち3種類以上を使用してください。

・大文字、小文字を区別して入力してください。

(2) 「OK」をクリックします。

→ 「Next」ボタンが表示されます

(3) 「Next」ボタンをクリックします

注) 入力したパスワードは忘れないようにメモを取って保管してください。


サーバータイプの選択

(1) 「Select server type」で「Broker＋Face Matching(Master)」を選択します。

(2) 「Select a valid function.」で運用モードの選択を行います。

登録顔/未登録顔検知モードで運用する場合は、「Registered face/unregistered face detection mode」を選択します。

登録顔検知モードで運用する場合は、「Registered face detection」を選択します。

(3) IPアドレス入力欄からPCのIPアドレスを選択します。

(4) 「Next」をクリックします。


ソフトウェアのインストール

(1) 「サーバータイプの選択」で「Next」をクリックすると、自動で「Java Runtime」、「PostgreSQL」、「Visual C++ 20xx runtime」がインストールされ、続いて「WV-ASF950」の使用許諾契約書が表示されます。

(2) 「使用許諾契約書に同意します」にチェックをし、「インストール」をクリックします。

注) 説明に使用している画面表示(バージョン表示など)は本ソフトウェアのバージョンにより異なります。

(3) 「完了」をクリックしてインストールを終了します。

注) 説明に使用している画面表示(バージョン表示など)は本ソフトウェアのバージョンにより異なります。

(4) 自動で本ソフトウェアに必要なデータベースが作成されます。

(5) ソフトウェアのインストール完了と「Next」をクリックするメッセージが表示され、「Next」ボタンが表示されたことを確認し、「Next」をクリックします。


サーバー設定

「Next」をクリックします。

注）サーバー設定はコンフィグツールで設定を行います。


セキュア設定

「Next」をクリックします。

注）セキュア設定はコンフィグツールで設定を行います。


ライセンス登録

マスターサーバー内のFM Nodeにはネットワークカメラ4台のライセンスが含まれており、その解除キー番号を設定します。

FM Nodeに5台以上のネットワークカメラを接続する場合、別途購入のWV-ASFE901W(カメラ拡張キット/1台)、WV-ASFE904W(カメラ拡張キット/4台)設定します。

アラーム対象の登録顔数を増やすには、WV-ASFE951W（顔登録拡張キット/10000件）の解除キー番号を設定します。

(1) MPR-ID(機器ID番号)を確認します。

MPR ID | 機器ID番号
Activation Key No. | 起動ID番号
Registration ID | 暗号ID番号
Registration Key | 解除キー番号

(2) キー管理システムで解除キー番号を発行しRegistration Key欄へ入力します。

続いて「Add」をクリックします。

項目を変更したり削除したりする場合は、リストから対象のキーを選択して、それぞれ「Modify」「Delete」をクリックします。

(3) 「Add Registration Key」をクリックします。

(4) ライセンスの「Status」が「Activated」となっていることを確認します。

注）登録後に登録の変更、削除はできません。

(5) 「Finish」をクリックします。

(6) インストールを完了するには、PCの再起動が必要になります。

「キャンセル」をクリックすると自動で再起動はしませんので、後で必ず手動で再起動を行ってください。


スタートアップツールによる操作/設定(スレーブサーバー)

スレーブサーバーのDVD-ROMドライブに付属のDVD-ROMをセットします。

マスターサーバーのみでスレーブサーバーがないシステム構成の場合、トピック『コンフィグツールによる操作/設定(マスターサーバー)』へ移行してください。

注)　作業はすべて管理者権限を持つアカウントでログインした状態で行ってください。

スタートアップツールの起動

データベースのパスワード設定

サーバータイプの選択

ソフトウェアのインストール

サーバー設定

セキュア設定

ライセンス登録


データベースのパスワード設定

(1) パスワード入力欄にマスターサーバーで設定したパスワードを入力します。

(2) 「OK」をクリックします。

→ 「Next」ボタンが表示されます

(3) 「Next」ボタンをクリックします

注) 入力したパスワードは忘れないようにメモを取って保管してください。


サーバータイプの選択

(1) 「Select server type」で「Face Matching(Slave)」を選択します。

(2) 「Select a valid function.」でマスターサーバーで設定した運用モードを選択します。

(3) IPアドレス入力欄からPCのIPアドレスを選択します。

(4) Broker NodeのIPアドレス入力欄にマスターサーバー(Broker Node)のIPアドレスを入力します。

(5) 「Next」をクリックします。

注) 「Next」をクリックした際にエラーが表示される場合、マスターサーバーでトピック『スタートアップツールによる操作/設定(マスターサーバー)』の作業を実施していない、またはスレーブサーバーとマスターサーバー間の通信ができていない可能性があります。
設定作業やネットワークを確認した後に作業を再開してください。


ライセンス登録

マスターサーバー内のFM Nodeにはネットワークカメラ4台のライセンスが含まれており、その解除キー番号を設定します。

FM Nodeに5台以上のネットワークカメラを接続する場合、別途購入のWV-ASFE901W(カメラ拡張キット/1台)、WV-ASFE904W(カメラ拡張キット/4台)設定します。

アラーム対象の登録顔数を増やすには、WV-ASFE951W（顔登録拡張キット/10000件）の解除キー番号を設定します。

(1) MPR-ID(機器ID番号)を確認します。

MPR ID | 機器ID番号
Activation Key No. | 起動ID番号
Registration ID | 暗号ID番号
Registration Key | 解除キー番号

(2) キー管理システムで解除キー番号を発行しRegistration Key欄へ入力します。

続いて「Add」をクリックします。

項目を変更したり削除したりする場合は、リストから対象のキーを選択して、それぞれ「Modify」「Delete」をクリックします。

(3) 「Add Registration Key」をクリックします。

(4) ライセンスの「Status」が「Activated」となっていることを確認します。

注）登録後に登録の変更、削除はできません。

(5) 「Finish」をクリックします。

(6) インストールを完了するには、PCの再起動が必要になります。

「OK」をクリックするとPCは再起動します。

「キャンセル」をクリックするとPCは再起動せず、スタートアップツールが終了します。


コンフィグツールによる操作/設定(マスターサーバー)

コンフィグツールの起動

カメラ登録

クライアント端末登録

I/O装置登録

サーバー設定

セキュア設定

ライセンス登録

サービスプロセス起動


コンフィグツールの起動

コンフィグツールを起動します。

(1) デスクトップにある「WV-ASF950ConfigurationTool」のショートカットをダブルクリックして実行します。

コンフィグツールのメイン画面が表示されます。

コンフィグツールを起動すると、マスターサーバー内の設定情報を取込み、Broker NodeのIPアドレスが表示され設定済みのシステム構成機器がツリー表示されます。

画面右上のプルダウンメニューで、表示言語を日本語と英語を切り替えられます。

注) マスターサーバーのみのシステム構成の場合、スレーブサーバー内のFM Nodeは表示されません。

(2) 設定の前に、以下の操作でアプリケーションを停止します。

① 「サービスプロセス管理」タブをクリックします。

② 「停止」をクリックします

③ すべてのプロセスが「停止」と表示されることを確認します。


カメラ登録

マスターサーバーのみのシステム構成の場合はマスターサーバー内のFM Node、スレーブサーバーがあるシステム構成の場合はマスターサーバー内のFM Nodeとスレーブサーバー内のFM Nodeに割り付けるカメラを登録します。

(1) 以下のどちらかの操作をします。

①マスターサーバー内のFM Nodeを選択し、「カメラ追加」をクリックします。

②マスターサーバー内のFM Nodeで右クリックし、「カメラ追加」をクリックします。

(2) 割り当てるカメラのIPアドレス、カメラの認証情報(ユーザー名、パスワード)を入力し、SSLでのカメラへの接続On/Offを選択して「接続」ボタンをクリックします。

(3) 「接続完了」の表示の後、接続するシステムの種別を選択します。

GUID

カメラを識別するID

接続するシステムを選択し、GUIDを設定します

注）接続するシステムに合わせて、適切なGUIDを選択してください。異なるGUIDでカメラを登録すると、クライアント画面の機器ツリーにカメラが表示されず、アラームも発報されません。

(4) 「カメラ設定」の項目を入力します。

「顔検出機能」を「オン」、「顔認証サーバーIPアドレス」に顔画像送信先のサーバーのIPアドレスを選択します。

「顔検出感度」は必要に応じて変更します。

顔検出機能 | 顔検出機能のオン/オフ
顔検出感度 | 顔検出感度 （低/中/高）
顔認証サーバーIPアドレス | 顔画像の送信先(FM Node)のIPアドレス
スーパーダイナミック | スーパーダイナミック機能のオン/オフ
ベストショットSSL通信 | ベストショットの送信にSSL通信をする/しない
マスク顔検出 | マスク顔の検出設定 (オフ/低/中低/中/中高/高(推奨))

カメラごとにアラーム通知端末を選択する場合は、「全選択」のチェックをはずし、表示されるアラーム通知端末のリストから、通知先をチェックボックスで選択します。

(5) 続けて別のカメラを登録する場合は「追加」、そうでない場合は「追加して閉じる」をクリックします。

(6) マスターサーバー内のFM Nodeにカメラが登録されたことを確認します。

①システム構成機器のツリーに登録したカメラが表示されている。

②FM Nodeを選択し、FM Nodeのカメラリストに登録したカメラが表示されている。

(7) マスターサーバー内のFM Nodeに割り付ける別のカメラがある場合、またはスレーブサーバーがある場合、同様の手順で登録します。

(8) カメラの設定を確認する場合は、システム構成機器のツリーからカメラを選択します。


クライアント端末登録

本システムで動作させるクライアント端末を登録します。

(1) 以下のどちらかの操作をします。

①「端末グループ」を選択し、「端末追加」をクリック

②「端末グループ」で右クリックし、「端末追加」をクリック

(2) クライアント端末の設定を入力します。

MACアドレスは直接入力するか、端末IPアドレスを入力して検索ボタンをおすことで設定できます。

または、MACアドレス参照機能を使用して入力します。

MACアドレス参照機能の使い方は本トピックの補足欄をご覧ください。

端末タイプ | クライアント端末の種別
備考 | クライアント端末を識別するための備考欄
端末IPアドレス | クライアント端末のIPアドレス
ポート番号 | クライアント端末へのアラーム通知ポート番号
MACアドレス | クライアント端末のMACアドレス

(3) 続けて別のクライアント端末を登録する場合は「追加」、そうでない場合は「追加して閉じる」をクリックします。

(4) 本システムにクライアント端末が登録されたことを確認します。

①システム構成機器のツリーに登録したクライアント端末が表示されている。

②「端末グループ」を選択し、クライアント端末リストに登録したクライアント端末が表示されている。

(5) 別のクライアント端末がある場合、同様の手順で登録します。

【補足】MACアドレス参照機能

(1) 端末IPアドレスを入力していない状態で、検索ボタンをクリックします。

(2) IPアドレスの検索範囲を入力し、「検索」ボタンをクリックします。

(3) MACアドレス欄にクライアント端末のMACアドレスが表示されたことを確認し、選択して「OK」ボタンをクリックします。


I/O装置登録

本システムで動作させるI/O装置を登録します。

(1) 以下のいずれかの操作をします。

① 「I/O装置管理」を選択し、「I/O装置追加」をクリック

② 「I/O装置管理」で右クリックし、「I/Oユニット追加」をクリック

③ 「I/O装置管理」を選択し、「追加」をクリック

(2) 端末側のI/O装置のポート番号を設定し、「追加して閉じる」をクリックします。

→　完了確認メッセージで「OK」ボタンをクリックします。

(3) 以下のどちらかの操作をします。

④ 「I/O装置管理」を選択し、「I/O装置追加」をクリック

⑤ 「I/O装置管理」で右クリックし、「I/Oユニット追加」をクリック

→　I/O装置の設定を入力します。

I/O装置モデル | I/O装置のモデル（ADAM6256/ADAM6050/ADAM6060/ADAM6066）
I/O装置IPアドレス | I/O装置のIPアドレス
ポート番号 | I/O装置へのアラーム通知ポート番号
関連I/Oアクション設定 | カメラIPアドレス：アラーム連動させるカメラのIPアドレス ビット位置：アラーム連動するI/O装置のビット位置 ON時間(秒)：アラーム連動させる時間

(4) 「アクション追加」をクリックします。

    関連I/Oアクションに設定したI/O装置の動作が追加されたことを確認します。

(5) 続けて別のI/O装置の動作を登録する場合は「追加」、そうでない場合は「追加して閉じる」をクリックします。

(6) 本システムにI/O装置が登録されたことを確認します。

(ア) システム構成機器のツリーに登録したI/O装置が表示されている。

(イ) 追加したI/O装置を選択し、関連I/Oアクションに設定したI/O装置の動作設定が表示されている。

(7) 別のI/O装置がある場合、(3)から同様の手順で登録します。

注）I/O装置は、装置の設定機能を使い、IPによるアクセス制限の設定、およびパスワードを初期値から変更することを必ず行ってください。


サーバー設定

インストール時に設定しなかった場合、顔検索データの保存や、画像データの保存先を設定できます。

(1) 顔検索データの保存期間・件数の設定

顔検索データを保存する場合は「保存する」を選択し、保存期間と保存件数を入力します。

保存期間 | 最大366日（初期値：31）
保存件数 | 最大1000万件（初期値：5000000）

設定を反映させるには「顔検索データ」ボタンを押します。

変更確認のためのダイアログが表示されますので、Windowsにログオンするユーザー名とパスワードを入力してOKボタンを押すと、設定が反映されます。

※ 他の設定も含め一度ログオンすると、以降コンフィグツールを終了するまで表示されません。

(2) 顔認証アラーム履歴データの保存期間の設定

顔認証アラーム履歴データの保存期間を入力します。

保存期間

最大366日（初期値：31）

設定を反映させるには「顔認証アラーム履歴データ」ボタンを押します。

変更確認のためのダイアログが表示されますので、Windowsにログオンするユーザー名とパスワードを入力してOKボタンを押すと、設定が反映されます。

※ 他の設定も含め一度ログオンすると、以降コンフィグツールを終了するまで表示されません。

(3) 年齢／性別判定統計データの保存期間の設定

年齢／性別判定統計データの保存期間を入力します。

保存期間

最大366日（初期値：186）

設定を反映させるには「年齢／性別判定統計データ」ボタンを押します。

変更確認のためのダイアログが表示されますので、Windowsにログオンするユーザー名とパスワードを入力してOKボタンを押すと、設定が反映されます。

※ 他の設定も含め一度ログオンすると、以降コンフィグツールを終了するまで表示されません。

(4) 画像データ保存フォルダの設定

画像データの保存フォルダの設定をします。

初期状態では、「C:\ASF900\img」フォルダに保存されます。

変更する場合は、保存フォルダのフルパスを入力するか、「参照」ボタンをクリックして保存フォルダを選択します。

注）運用途中で変更すると、変更前に保存されていた画像は表示できなくなりますのでご注意ください。

設定を反映させるには「画像データの保存先」ボタンを押します。


セキュア設定

(1) セキュア通信の設定

カメラ～サーバー間、クライアント～サーバー間、マスター～スレーブサーバー間について、SSLによる通信を行うか設定します。

SSLを使う場合は、「SSL通信あり」を選択し、使わない場合は「SSL通信なし」を選択します。
ポート番号は、SSL通信なし：80、SSL通信あり：443になります。

設定するには「SSL通信設定」ボタンを押します。

(2) データ暗号化の設定

画像や人物登録情報のデータ暗号化の設定をします。

暗号化キーを入力すると、データが暗号化されます。

暗号化機能を使わない場合は、暗号化キーは入力しないでください。

入力可能文字数：8～32文字

・英字(大文字)、英字(小文字)、数字、記号のうち3種類以上を使用してください。

・大文字、小文字を区別して入力してください。

「暗号化キー表示」のチェックボックスにより、キーの文字を表示することができます。

注）運用途中で暗号する/しないを切り替える、または暗号化キーを変更する場合、再インストールが必要になりますのでご注意ください。

設定するには「暗号化キー登録」ボタンを押します。

変更確認のためのダイアログが表示されますので、Windowsにログオンするユーザー名とパスワードを入力してOKボタンを押すと、設定が反映されます。

※ 他の設定も含め一度ログオンすると、以降コンフィグツールを終了するまで表示されません。


ライセンス登録

FM Nodeにはネットワークカメラ4台のライセンスが含まれており、その解除キー番号を設定します。

FM Nodeに5台以上のネットワークカメラを接続する場合、別途購入のWV-ASFE901W(カメラ拡張キット/1台)、WV-ASFE904W(カメラ拡張キット/4台)設定します。

アラーム対象の登録顔数を増やすには、WV-ASFE951W（顔登録拡張キット/10000件）の解除キー番号を設定します。

(1) 機器ID番号を確認します。

(2) キー管理システムで解除キー番号を発行し解除キー欄へ入力します。

続いて「追加」をクリックします。

項目を変更したり削除したりする場合は、リストから対象のキーを選択して、それぞれ「変更」「削除」をクリックします。

(3) 「解除キー登録」ボタンをクリックします。

(4) ライセンスの「状態」が「Activated」となっていることを確認します。

(5) 解除キーのバックアップをする場合は、「バックアップ」ボタンを押し、保存先のフォルダを選択して「OK」ボタンを押します。
リストアする場合は「リストア」ボタンを押した後、バックアップしたファイルを選択します。ライセンス内容が表示されるので、確認して「OK」ボタンを押してリストアします。


サービスプロセス起動

マスターサーバー内のBroker NodeおよびFM Nodeのサービスプロセスを起動します。

(1) 「サービスプロセス管理」タブを選択します。

(2) 「開始」をクリックします。

(3) すべてのサービスプロセスが「実行中」と表示されることを確認します。

「更新」ボタンで、状態表示を更新することができます。


コンフィグツールによる操作/設定(スレーブサーバー)

コンフィグツールの起動

サービスプロセス起動


コンフィグツールの起動

コンフィグツールを起動します。

(1) デスクトップにある「WV-ASF950ConfigurationTool」のショートカットをダブルクリックして実行します。

コンフィグツールのメイン画面が表示されます。

コンフィグツールを起動すると、マスターサーバー内の設定情報を取込み、Broker NodeのIPアドレスが表示され設定済みのシステム構成機器がツリー表示されます。

画面右上のプルダウンメニューで、表示言語を日本語と英語を切り替えられます。

(2) 設定の前に、以下の操作でアプリケーションを停止します。

①「サービスプロセス管理」タブをクリックします。

②「停止」をクリックします

③すべてのプロセスが「停止」と表示されることを確認します。

注)「ASF950BRK01」、「ASF950BRK03」、「ASF950BrokerManager」、「ASF950IOManager」は「未インストール」と表示されます。


サービスプロセス起動

設定後、スレーブサーバー内のFM Nodeのサービスプロセスを起動します。

(1) 「サービスプロセス管理」タブを選択します。

(2) 「開始」をクリックします。

(3) すべてのサービスプロセスが「実行中」と表示されることを確認します。

注)「ASF950BRK01」、「ASF950BRK03」、「ASF950BrokerManager」、「ASF950IOManager」は「未インストール」と表示されます。


スケジュールによる再起動の設定(マスター/スレーブサーバー)

タスクスケジューラーを用いて定期的にサーバーを再起動する場合は、下記のファイルを実行し、

タスクスケジューラーに再起動スケジュールを設定します。

C:\ASF900\tool\regist_server_restart.bat

注)作業はすべて管理者権限を持つアカウントでログインした状態で行ってください。

初期設定は毎日4:00に再起動するようになっています。環境に応じて変更してください。


シャットダウンの監視 (マスター/スレーブサーバー)

Windowsログイン中、マスター/スレーブサーバーのプロセスが稼働中にWindowsのシャットダウン操作をした場合、シャットダウン監視プログラム(ASF950ShutdownMonitor)が、プロセスの終了までシャットダウンを一時停止します。

シャットダウン一時停止中は、以下の画面が表示されます。（画面はWindows 10の場合）

通常、約2分でプロセスが終了しシャットダウンします。

プロセスが終了せずに30分経過した場合は、プロセスは強制終了されWindowsはシャットダウンします。


システム運用開始後の設定変更手順

システム運用開始後に生じることがある設定変更手順について説明します。

システム構成機器の追加

システム構成機器の削除


システム構成機器の追加

FM Node、カメラ、クライアント端末を追加する場合の手順を説明します。

FM Nodeの追加

カメラの追加

クライアント端末の追加

I/O装置の追加

ライセンスの追加


FM Nodeの追加

(1) トピック『新規構築時の手順』－『スタートアップツールによる操作/設定(スレーブサーバー)』を参照し、設定します。


カメラの追加

(1) デスクトップにある「WV-ASF950ConfigurationTool」のショートカットをダブルクリックして実行します。

コンフィグツールのメイン画面が表示されます。

(2) カメラの追加にあたりカメラ拡張キットのライセンスの登録が必要の場合、以下の操作をします。

カメラ拡張キットのライセンスの登録が不要の場合は手順(4)へ移行します。

①「ライセンス管理」タブをクリックします。

② キー管理システムで解除キー番号を発行し解除キー欄へ入力し、「追加」をクリックします。

③「解除キー登録」をクリックします。

④ ライセンスの「状態」が「Activated」になっていることを確認します。

注) 「ライセンス管理」タブは、コンフィグツールを起動したPCに対する操作/設定となります。

コンフィグツールを起動したPCから、別のPCに対してライセンスを登録することはできません。

そのため手順(1)でカメラを追加するFM Nodeのサーバーでコンフィグツールを起動しています。

(3) 「サーバー構成」タブをクリックします。

(4) トピック『新規構築時の手順』－『コンフィグツールによる操作/設定(マスターサーバー)』または『コンフィグツールによる操作/設定(スレーブサーバー)』－『カメラ登録』を参照し、追加するカメラを登録します。

(5) 「サービスプロセス管理」タブをクリックします。

注)「サービスプロセス管理」タブは、コンフィグツールを起動したPCに対する操作するものです。

コンフィグツールを起動したPCとは異なるPCに対してプロセスの操作はできません。

(6) 「停止」をクリックし、すべてのプロセスが「停止」と表示されることを確認します。

注) マスターサーバーのプロセス停止はシステム全体の運用に影響が与えますのでご注意ください。

注) スレーブサーバーでは「ASF950BRK01」、「ASF950BRK03」、「ASF950BrokerManager」、「ASF950IOManager」は「未インストール」のままとなります。

(7) 「開始」をクリックし、すべてのプロセスが「実行中」と表示されることを確認します。

注) スレーブサーバーでは「ASF950BRK01」、「ASF950BRK03」、「ASF950BrokerManager」、「ASF950IOManager」は「未インストール」のままとなります。

注) カメラを追加するFM Nodeのプロセスを再起動することで登録したカメラが有効な状態となります。
(カメラを追加するFM Nodeがスレーブサーバーの場合、マスターサーバーに対するプロセスの再起動は必要ありません。)
プロセスの再起動を実施しないと、システム構成機器のツリーに登録したカメラが表示されますが、有効な状態となっていませんのでご注意ください。


クライアント端末の追加

(1) デスクトップにある「WV-ASF950ConfigurationTool」のショートカットをダブルクリックして実行します。

コンフィグツールのメイン画面が表示されます。

(2) トピック『新規構築時の手順』－『コンフィグツールによる操作/設定(マスターサーバー)』－『クライアント端末登録』を参照し、追加するクライアント端末を登録します。

(3) 「サービスプロセス管理」タブをクリックします。

(4) 「停止」をクリックし、すべてのプロセスが「停止」と表示されることを確認します。

注) マスターサーバーのプロセス停止はシステム全体の運用に影響が与えますのでご注意ください。

(5) 「開始」をクリックし、すべてのプロセスが「実行中」と表示されることを確認します。

(6) スレーブサーバーのデスクトップにある「WV-ASF950ConfigurationTool」のショートカットをダブルクリックして実行します。

コンフィグツールのメイン画面が表示されます。

(7) 手順(3)～(5)を参照し、スレーブサーバー内のFM Nodeのプロセスを再起動します。

注) スレーブサーバーでは「ASF950BRK01」、「ASF950BRK03」、「ASF950BrokerManager」、「ASF950IOManager」は「未インストール」のままとなります。

注) マスターサーバーおよびスレーブサーバーのプロセスの再起動を実施により登録したカメラが有効な状態となります。
プロセスの再起動を実施しないと、システム構成機器のツリーに登録したクライアント端末が表示されますが、有効な状態となっていませんのでご注意ください。


I/O装置の追加

(1) デスクトップにある「WV-ASF950ConfigurationTool」のショートカットをダブルクリックして実行します。

コンフィグツールのメイン画面が表示されます。

(2) トピック『新規構築時の手順』－『コンフィグツールによる操作/設定(マスターサーバー)』－『I/O装置登録』を参照し、追加するI/O装置を登録します。

(3) 「サービスプロセス管理」タブをクリックします。

(4) 「停止」をクリックし、すべてのプロセスが「停止」と表示されることを確認します。

注) マスターサーバーのプロセス停止はシステム全体の運用に影響が与えますのでご注意ください。

(5) 「開始」をクリックし、すべてのプロセスが「実行中」と表示されることを確認します。

(6) スレーブサーバーのデスクトップにある「WV-ASF950ConfigurationTool」のショートカットをダブルクリックして実行します。

コンフィグツールのメイン画面が表示されます。

(7) 手順(3)～(5)を参照し、スレーブサーバー内のFM Nodeのプロセスを再起動します。

注) スレーブサーバーでは「ASF950BRK01」、「ASF950BRK03」、「ASF950BrokerManager」、「ASF950IOManager」は「未インストール」のままとなります。

注) マスターサーバーおよびスレーブサーバーのプロセスの再起動を実施により登録したカメラが有効な状態となります。
プロセスの再起動を実施しないと、システム構成機器のツリーに登録したI/O装置が表示されますが、有効な状態となっていませんのでご注意ください。


ライセンスの追加

FM Nodeにはネットワークカメラ4台のライセンスが含まれており、その解除キー番号を設定します。

FM Nodeに5台以上のネットワークカメラを接続する場合、別途購入のWV-ASFE901W(カメラ拡張キット/1台)、WV-ASFE904W(カメラ拡張キット/4台)設定します。

アラーム対象の登録顔数を増やすには、WV-ASFE951W（顔登録拡張キット/10000件）の解除キー番号を設定します。

(1) デスクトップにある「WV-ASF950ConfigurationTool」のショートカットをダブルクリックして実行します。
コンフィグツールのメイン画面が表示されます。

(2) 「ライセンス管理」タブで、機器ID番号を確認します。

(3) キー管理システムで解除キー番号を発行し解除キー欄へ入力します。

続いて「追加」をクリックします。

項目を変更したり削除したりする場合は、リストから対象のキーを選択して、それぞれ「変更」「削除」をクリックします。

(4) 「解除キー登録」をクリックします。

(5) ライセンスの「状態」が「Activated」となっていることを確認します。

注）登録後に登録の変更、削除はできません。

(6) 「サービスプロセス管理」タブをクリックします。

(7) 「停止」をクリックし、すべてのプロセスが「停止」と表示されることを確認します。

注) マスターサーバーのプロセス停止はシステム全体の運用に影響が与えますのでご注意ください。

(8) 「開始」をクリックし、すべてのプロセスが「実行中」と表示されることを確認します。

(9) スレーブサーバーのデスクトップにある「WV-ASF950ConfigurationTool」のショートカットをダブルクリックして実行します。

コンフィグツールのメイン画面が表示されます。

(10) 手順(5)～(7)を参照し、スレーブサーバー内のFM Nodeのプロセスを再起動します。

注) スレーブサーバーでは「ASF950BRK01」、「ASF950BRK03」、「ASF950BrokerManager」、「ASF950IOManager」は「未インストール」のままとなります。

注) マスターサーバーおよびスレーブサーバーのプロセスの再起動を実施により登録したカメラが有効な状態となります。
プロセスの再起動を実施しないと、システム構成機器のツリーに登録したクライアント端末が表示されますが、有効な状態となっていませんのでご注意ください。


システム構成機器の削除

FM Node、カメラ、クライアント端末を削除する場合の手順を説明します。

FM Nodeの削除

カメラの削除

クライアント端末の削除

I/O装置の削除


FM Nodeの削除

(1) デスクトップにある「WV-ASF950ConfigurationTool」のショートカットをダブルクリックして実行します。

コンフィグツールのメイン画面が表示されます。

注) コンフィグツールを起動するとマスターサーバー内のBroker Nodeの情報を取得し、システム機器構成のツリーを表示します。
スレーブサーバー内にもBroker Nodeの基本情報があり、その情報を元にマスターサーバー内のBrokerNodeへ情報の取得にいくため、同一のシステム機器構成のツリーが表示されます。

(2) 削除するFM Nodeを選択します。

(3) 「削除」をクリックします。

(4) FM Node削除を確認するダイアログで「OK」をクリックします。


カメラの削除

(1) デスクトップにある「WV-ASF950ConfigurationTool」のショートカットをダブルクリックして実行します。
コンフィグツールのメイン画面が表示されます。

(2) 削除するカメラを選択します。

(3) 「削除」をクリックします。

(4) カメラ削除を確認するダイアログで「OK」をクリックします。

(5) 「サービスプロセス管理」タブをクリックします。

(6) 「停止」をクリックし、すべてのプロセスが「停止」と表示されることを確認します。

注) マスターサーバーのプロセス停止はシステム全体の運用に影響が与えますのでご注意ください。

注) スレーブサーバーでは「ASF950BRK01」、「ASF950BRK03」、「ASF950BrokerManager」、「ASF950IOManager」は「未インストール」のままとなります。

(7) 「開始」をクリックし、すべてのプロセスが「実行中」と表示されることを確認します。

注) カメラを削除するFM Nodeのプロセスを再起動することでカメラの削除が反映されます。　(カメラを削除するFM Nodeがスレーブサーバーの場合、マスターサーバーに対するプロセスの再起動は必要ありません。)
プロセスの再起動を実施しないと、システム構成機器のツリーから削除したカメラが表示されなくなりますが、削除が反映されていない状態ですのでご注意ください。


クライアント端末の削除

(1) デスクトップにある「WV-ASF950ConfigurationTool」のショートカットをダブルクリックして実行します。

コンフィグツールのメイン画面が表示されます。

(2) 削除するクライアント端末を選択します。

(3) 「削除」をクリックします。

(4) クライアント端末を確認するダイアログで「OK」をクリックします。

(5) 「サービスプロセス管理」タブをクリックします。

(6) 「停止」をクリックし、すべてのプロセスが「停止」と表示されることを確認します。

注) マスターサーバーのプロセス停止はシステム全体の運用に影響が与えますのでご注意ください。

(7) 「開始」をクリックし、すべてのプロセスが「実行中」と表示されることを確認します。

(8) スレーブサーバーのデスクトップにある「WV-ASF950ConfigurationTool」のショートカットをダブルクリックして実行します。
コンフィグツールのメイン画面が表示されます。

(9) 手順(5)～(7)を参照し、スレーブサーバー内のFM Nodeのプロセスを再起動します。

注) スレーブサーバーでは「ASF950BRK01」、「ASF950BRK03」、「ASF950BrokerManager」、「ASF950IOManager」は「未インストール」のままとなります。

注) マスターサーバーおよびスレーブサーバーのプロセスの再起動を実施によりクライアント端末の削除が反映されます。
プロセスの再起動を実施しないと、システム構成機器のツリーから削除したクライアント端末が表示されなくなりますが、削除が反映されていない状態ですのでご注意ください。


I/O装置の削除

(1) デスクトップにある「WV-ASF950ConfigurationTool」のショートカットをダブルクリックして実行します。

コンフィグツールのメイン画面が表示されます。

(2) 削除するI/O装置を選択します。

(3) 「削除」をクリックします。

(4) I/O装置の削除を確認するダイアログで「OK」をクリックします。

(5) 「サービスプロセス管理」タブをクリックします。

(6) 「停止」をクリックし、すべてのプロセスが「停止」と表示されることを確認します。

注) マスターサーバーのプロセス停止はシステム全体の運用に影響が与えますのでご注意ください。

(7) 「開始」をクリックし、すべてのプロセスが「実行中」と表示されることを確認します。

(8) スレーブサーバーのデスクトップにある「WV-ASF950ConfigurationTool」のショートカットをダブルクリックして実行します。
コンフィグツールのメイン画面が表示されます。

(9) 手順(5)～(7)を参照し、スレーブサーバー内のFM Nodeのプロセスを再起動します。

注) スレーブサーバーでは「ASF950BRK01」、「ASF950BRK03」、「ASF950BrokerManager」、「ASF950IOManager」は「未インストール」のままとなります。

注) マスターサーバーおよびスレーブサーバーのプロセスの再起動を実施によりI/O装置の削除が反映されます。
プロセスの再起動を実施しないと、システム構成機器のツリーから削除したI/O装置が表示されなくなりますが、削除が反映されていない状態ですのでご注意ください。


トラブルシュート

原因と対応

顔検索範囲の設定

複数のネットワークカードがあるPCの場合

複数のGPUボードがあるPCの場合


原因と対応

事 象 | 原 因 と 対 応
ディスク容量が不足している。 | 本機に蓄積した顔のサムネイル画像および、顔の特徴情報のデータベースを保存する空き容量が少なくなっています。 →システム管理者または販売店へご相談ください。
ネットワークカメラからの顔画像が受信できない | 以下の原因が考えられます。 ① 本機のシステム設定の間違い →本機に設定したネットワークカメラのMACアドレスまたはIPアドレスを確認してください。 ② ネットワークカメラに拡張機能ソフトウェアがインストールされていない →ネットワークカメラに拡張機能ソフトウェアをインストールしてください。 ③ ネットワークカメラのシステム設定の間違い →ネットワークカメラの顔画像の送信設定を確認してください。 顔画像の受信状況をツールソフトで確認できます。 詳しくはシステム管理者または販売店へお問い合わせください。
顔検索の結果が表示されない。 | 「サービスプロセス管理」のタブで、ASF950MSMのサービスが起動しているか確認してください。起動していない場合、本機のデータベースが破損している可能性があります。 破損しているデータベースをツールソフトで修復・初期化できます。詳しくはシステム管理者または販売店へお問い合わせください。
クライアント端末で、サーバー情報およびカメラ情報が取得できない。 | 以下の原因が考えられます。 ① クライアント端末のMACアドレスが登録されていない。 →サーバー構成タブで、使用する端末を登録してください。 ② FM Nodeでカメラの設定が有効になっていない。 →「サービスプロセス管理」のタブでサービスを再起動してください。
ASF950httpdが起動しない。 | 他のアプリケーションがポートを使用している可能性があります。 それらのアプリケーションをアンインストールした後、ASF950httpdが起動させてください。 また、プリンターのスプーラーサービスなどがポートを使用している場合があります。 その場合は、レジストリエディターを起動し、 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP を開きます。 「Start」の値を 「3」から「4」に変更し、Windowsを再起動します。 その後、ASF950httpdを起動させてください。


顔検索範囲の設定

顔検索機能の検索範囲と出力数を"C:\ASF900\batch\msm"フォルダの”MetaStorageManager.conf "ファイルで設定します。

* 変更後、ASF950MSMプロセスをASF950ConfigToolで再起動することで反映されます。

* 検索範囲、出力数を多くすると、検索時間がかかります。

MetaStorageManager.conf

<info name="mddb-max-pages" value="1"/> 出力数係数（～25）

<info name="mddb-max-nr" value="512"/> *変更しない

<info name="mddb-max-range-pages" value="5"/> 時間表示での検索範囲係数（②の最大数を超えない値）

<info name="mddb-max-range-time" value="24"/> 一覧表示での検索範囲（～336時間 ※14日）

① 出力件数

"mddb-max-nr" x "mddb-max-pages" = 512 x 1 =512 件

* この設定は、時間表示・一覧表示どちらにも有効です。

② 時間表示での検索範囲

"mddb-max-nr" x "mddb-max-pages" x " mddb-max-range-pages "

= 512 x 1 x 5 =2,560 件（最大128,000件まで）

③ 一覧表示での検索範囲

" mddb-max-range-time" = 24 時間（最大336時間まで ※14日）

検索範囲設定例

・時間表示での検索範囲

"mddb-max-nr" x "mddb-max-pages" x " mddb-max-range-pages "

= 512 x 1 x 5 =2,560 件

・一覧表示での検索範囲

" mddb-max-range-time" = 24 時間


複数のネットワークカードがあるPCの場合

複数のネットワークカードがあるPCの場合、本ソフトウェアがカメラやクライアントPCとの通信に使うネットワークカードのインターフェース メトリックの値を、一番小さい数値に設定してください。

例）

ネットワークカードA　インターフェース メトリック値： 1　（本ソフトウェアが通信に使う）

      ネットワークカードB　インターフェース メトリック値： 2

(1) Windowsのスタートメニューから「設定」を選択し、「Windowsの設定」を開きます。

「ネットワークとインターネット」を選択して開きます。

(2) 「ネットワークの状態」の画面で、「アダプターのオプションを変更する」を開きます。

(3) メトリック値を変更するネットワークを選択し、右クリックメニューから「プロパティ」を選択して開きます。

(4) 「インターネットプロトコルバージョン 4」を選択し、「プロパティ」ボタンを押します。

(5) 「詳細設定」ボタンを押します。

(6) 「自動メトリック」のチェックをはずし、「インターフェース　メトリック」の値を入力して、「OK」ボタンを押します。

(7) 他のネットワークも同じようにメトリックの値を設定します。


複数のGPUボードがあるPCの場合

複数のGPUボードがあるPCの場合、本ソフトウェアが処理に使うGPUボードを正しく認識できません。

下図のように、コントロールパネルのデバイスマネージャーを開き、ディスプレイアダプターの一覧から対応GPUボード1台以外のものを、右クリックメニューで「デバイスを無効にする」を選択し無効にしてください。


オープンソースソフトウェア

本ソフトウェアの一部はオープンソースソフトウェアを使用しています。関係する利用規約は、本ソフトウェアにも適用します。以下の著作権やライセンス情報に関するお問合せは当社ではお請けいたしかねます。

Apache

CodeIgniter

OpenCV

OpenSSL

PHP

PostgreSQL

Redis

PostgreSQL JDBC Driver

Intel Integrated Performance Primitives, Math Kernel Library

Microsoft Public License (Ms-PL)


Apache

Apache License

Version 2.0, January 2004

http://www.apache.org/licenses/

TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION

1. Definitions.

"License" shall mean the terms and conditions for use, reproduction,

and distribution as defined by Sections 1 through 9 of this document.

"Licensor" shall mean the copyright owner or entity authorized by

the copyright owner that is granting the License.

"Legal Entity" shall mean the union of the acting entity and all

other entities that control, are controlled by, or are under common

control with that entity. For the purposes of this definition,

"control" means (i) the power, direct or indirect, to cause the

direction or management of such entity, whether by contract or

otherwise, or (ii) ownership of fifty percent (50%) or more of the

outstanding shares, or (iii) beneficial ownership of such entity.

"You" (or "Your") shall mean an individual or Legal Entity

exercising permissions granted by this License.

"Source" form shall mean the preferred form for making modifications,

including but not limited to software source code, documentation

source, and configuration files.

"Object" form shall mean any form resulting from mechanical

transformation or translation of a Source form, including but

not limited to compiled object code, generated documentation,

and conversions to other media types.

"Work" shall mean the work of authorship, whether in Source or

Object form, made available under the License, as indicated by a

copyright notice that is included in or attached to the work

(an example is provided in the Appendix below).

"Derivative Works" shall mean any work, whether in Source or Object

form, that is based on (or derived from) the Work and for which the

editorial revisions, annotations, elaborations, or other modifications

represent, as a whole, an original work of authorship. For the purposes

of this License, Derivative Works shall not include works that remain

separable from, or merely link (or bind by name) to the interfaces of,

the Work and Derivative Works thereof.

"Contribution" shall mean any work of authorship, including

the original version of the Work and any modifications or additions

to that Work or Derivative Works thereof, that is intentionally

submitted to Licensor for inclusion in the Work by the copyright owner

or by an individual or Legal Entity authorized to submit on behalf of

the copyright owner. For the purposes of this definition, "submitted"

means any form of electronic, verbal, or written communication sent

to the Licensor or its representatives, including but not limited to

communication on electronic mailing lists, source code control systems,

and issue tracking systems that are managed by, or on behalf of, the

Licensor for the purpose of discussing and improving the Work, but

excluding communication that is conspicuously marked or otherwise

designated in writing by the copyright owner as "Not a Contribution."

"Contributor" shall mean Licensor and any individual or Legal Entity

on behalf of whom a Contribution has been received by Licensor and

subsequently incorporated within the Work.

2. Grant of Copyright License. Subject to the terms and conditions of

this License, each Contributor hereby grants to You a perpetual,

worldwide, non-exclusive, no-charge, royalty-free, irrevocable

copyright license to reproduce, prepare Derivative Works of,

publicly display, publicly perform, sublicense, and distribute the

Work and such Derivative Works in Source or Object form.

3. Grant of Patent License. Subject to the terms and conditions of

this License, each Contributor hereby grants to You a perpetual,

worldwide, non-exclusive, no-charge, royalty-free, irrevocable

(except as stated in this section) patent license to make, have made,

use, offer to sell, sell, import, and otherwise transfer the Work,

where such license applies only to those patent claims licensable

by such Contributor that are necessarily infringed by their

Contribution(s) alone or by combination of their Contribution(s)

with the Work to which such Contribution(s) was submitted. If You

institute patent litigation against any entity (including a

cross-claim or counterclaim in a lawsuit) alleging that the Work

or a Contribution incorporated within the Work constitutes direct

or contributory patent infringement, then any patent licenses

granted to You under this License for that Work shall terminate

as of the date such litigation is filed.

4. Redistribution. You may reproduce and distribute copies of the

Work or Derivative Works thereof in any medium, with or without

modifications, and in Source or Object form, provided that You

meet the following conditions:

(a) You must give any other recipients of the Work or

Derivative Works a copy of this License; and

(b) You must cause any modified files to carry prominent notices

stating that You changed the files; and

(c) You must retain, in the Source form of any Derivative Works

that You distribute, all copyright, patent, trademark, and

attribution notices from the Source form of the Work,

excluding those notices that do not pertain to any part of

the Derivative Works; and

(d) If the Work includes a "NOTICE" text file as part of its

distribution, then any Derivative Works that You distribute must

include a readable copy of the attribution notices contained

within such NOTICE file, excluding those notices that do not

pertain to any part of the Derivative Works, in at least one

of the following places: within a NOTICE text file distributed

as part of the Derivative Works; within the Source form or

documentation, if provided along with the Derivative Works; or,

within a display generated by the Derivative Works, if and

wherever such third-party notices normally appear. The contents

of the NOTICE file are for informational purposes only and

do not modify the License. You may add Your own attribution

notices within Derivative Works that You distribute, alongside

or as an addendum to the NOTICE text from the Work, provided

that such additional attribution notices cannot be construed

as modifying the License.

You may add Your own copyright statement to Your modifications and

may provide additional or different license terms and conditions

for use, reproduction, or distribution of Your modifications, or

for any such Derivative Works as a whole, provided Your use,

reproduction, and distribution of the Work otherwise complies with

the conditions stated in this License.

5. Submission of Contributions. Unless You explicitly state otherwise,

any Contribution intentionally submitted for inclusion in the Work

by You to the Licensor shall be under the terms and conditions of

this License, without any additional terms or conditions.

Notwithstanding the above, nothing herein shall supersede or modify

the terms of any separate license agreement you may have executed

with Licensor regarding such Contributions.

6. Trademarks. This License does not grant permission to use the trade

names, trademarks, service marks, or product names of the Licensor,

except as required for reasonable and customary use in describing the

origin of the Work and reproducing the content of the NOTICE file.

7. Disclaimer of Warranty. Unless required by applicable law or

agreed to in writing, Licensor provides the Work (and each

Contributor provides its Contributions) on an "AS IS" BASIS,

WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or

implied, including, without limitation, any warranties or conditions

of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A

PARTICULAR PURPOSE. You are solely responsible for determining the

appropriateness of using or redistributing the Work and assume any

risks associated with Your exercise of permissions under this License.

8. Limitation of Liability. In no event and under no legal theory,

whether in tort (including negligence), contract, or otherwise,

unless required by applicable law (such as deliberate and grossly

negligent acts) or agreed to in writing, shall any Contributor be

liable to You for damages, including any direct, indirect, special,

incidental, or consequential damages of any character arising as a

result of this License or out of the use or inability to use the

Work (including but not limited to damages for loss of goodwill,

work stoppage, computer failure or malfunction, or any and all

other commercial damages or losses), even if such Contributor

has been advised of the possibility of such damages.

9. Accepting Warranty or Additional Liability. While redistributing

the Work or Derivative Works thereof, You may choose to offer,

and charge a fee for, acceptance of support, warranty, indemnity,

or other liability obligations and/or rights consistent with this

License. However, in accepting such obligations, You may act only

on Your own behalf and on Your sole responsibility, not on behalf

of any other Contributor, and only if You agree to indemnify,

defend, and hold each Contributor harmless for any liability

incurred by, or claims asserted against, such Contributor by reason

of your accepting any such warranty or additional liability.

END OF TERMS AND CONDITIONS


CodeIgniter

The MIT License (MIT)

Copyright (c) 2014 - 2018, British Columbia Institute of Technology

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the “Software”), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.


OpenCV

License Agreement

For Open Source Computer Vision Library

(3-clause BSD License)

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

•Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

•Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

•Neither the names of the copyright holders nor the names of the contributors may be used to endorse or promote products derived from this software without specific prior written permission.

This software is provided by the copyright holders and contributors “as is” and any express or implied warranties, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose are disclaimed. In no event shall copyright holders or contributors be liable for any direct, indirect, incidental, special, exemplary, or consequential damages (including, but not limited to, procurement of substitute goods or services; loss of use, data, or profits; or business interruption) however caused and on any theory of liability, whether in contract, strict liability, or tort (including negligence or otherwise) arising in any way out of the use of this software, even if advised of the possibility of such damage.


OpenSSL

This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/).

LICENSE ISSUES

==============

The OpenSSL toolkit stays under a double license, i.e. both the conditions of

the OpenSSL License and the original SSLeay license apply to the toolkit.

See below for the actual license texts.

OpenSSL License

---------------

/* ====================================================================

* Copyright (c) 1998-2018 The OpenSSL Project. All rights reserved.

*

* Redistribution and use in source and binary forms, with or without

* modification, are permitted provided that the following conditions

* are met:

*

* 1. Redistributions of source code must retain the above copyright

* notice, this list of conditions and the following disclaimer.

*

* 2. Redistributions in binary form must reproduce the above copyright

* notice, this list of conditions and the following disclaimer in

* the documentation and/or other materials provided with the

* distribution.

*

* 3. All advertising materials mentioning features or use of this

* software must display the following acknowledgment:

* "This product includes software developed by the OpenSSL Project

* for use in the OpenSSL Toolkit. (http://www.openssl.org/)"

*

* 4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to

* endorse or promote products derived from this software without

* prior written permission. For written permission, please contact

* openssl-core@openssl.org.

*

* 5. Products derived from this software may not be called "OpenSSL"

* nor may "OpenSSL" appear in their names without prior written

* permission of the OpenSSL Project.

*

* 6. Redistributions of any form whatsoever must retain the following

* acknowledgment:

* "This product includes software developed by the OpenSSL Project

* for use in the OpenSSL Toolkit (http://www.openssl.org/)"

*

* THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY

* EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE

* IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR

* PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR

* ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,

* SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT

* NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;

* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)

* HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,

* STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)

* ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED

* OF THE POSSIBILITY OF SUCH DAMAGE.

* ====================================================================

*

* This product includes cryptographic software written by Eric Young

* (eay@cryptsoft.com). This product includes software written by Tim

* Hudson (tjh@cryptsoft.com).

*

*/

Original SSLeay License

-----------------------

/* Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com)

* All rights reserved.

*

* This package is an SSL implementation written

* by Eric Young (eay@cryptsoft.com).

* The implementation was written so as to conform with Netscapes SSL.

*

* This library is free for commercial and non-commercial use as long as

* the following conditions are aheared to. The following conditions

* apply to all code found in this distribution, be it the RC4, RSA,

* lhash, DES, etc., code; not just the SSL code. The SSL documentation

* included with this distribution is covered by the same copyright terms

* except that the holder is Tim Hudson (tjh@cryptsoft.com).

*

* Copyright remains Eric Young's, and as such any Copyright notices in

* the code are not to be removed.

* If this package is used in a product, Eric Young should be given attribution

* as the author of the parts of the library used.

* This can be in the form of a textual message at program startup or

* in documentation (online or textual) provided with the package.

*

* Redistribution and use in source and binary forms, with or without

* modification, are permitted provided that the following conditions

* are met:

* 1. Redistributions of source code must retain the copyright

* notice, this list of conditions and the following disclaimer.

* 2. Redistributions in binary form must reproduce the above copyright

* notice, this list of conditions and the following disclaimer in the

* documentation and/or other materials provided with the distribution.

* 3. All advertising materials mentioning features or use of this software

* must display the following acknowledgement:

* "This product includes cryptographic software written by

* Eric Young (eay@cryptsoft.com)"

* The word 'cryptographic' can be left out if the rouines from the library

* being used are not cryptographic related :-).

* 4. If you include any Windows specific code (or a derivative thereof) from

* the apps directory (application code) you must include an acknowledgement:

* "This product includes software written by Tim Hudson (tjh@cryptsoft.com)"

*

* THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND

* ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE

* IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE

* ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE

* FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL

* DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS

* OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)

* HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT

* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY

* OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF

* SUCH DAMAGE.

*

* The licence and distribution terms for any publically available version or

* derivative of this code cannot be changed. i.e. this code cannot simply be

* copied and put under another distribution licence

* [including the GNU Public Licence.]

*/


PHP

This product includes PHP, freely available from <http://www.php.net/software/>.

--------------------------------------------------------------------

The PHP License, version 3.01

Copyright (c) 1999 - 2018 The PHP Group. All rights reserved.

--------------------------------------------------------------------

Redistribution and use in source and binary forms, with or without

modification, is permitted provided that the following conditions

are met:

1. Redistributions of source code must retain the above copyright

notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright

notice, this list of conditions and the following disclaimer in

the documentation and/or other materials provided with the

distribution.

3. The name "PHP" must not be used to endorse or promote products

derived from this software without prior written permission. For

written permission, please contact group@php.net.

4. Products derived from this software may not be called "PHP", nor

may "PHP" appear in their name, without prior written permission

from group@php.net. You may indicate that your software works in

conjunction with PHP by saying "Foo for PHP" instead of calling

it "PHP Foo" or "phpfoo"

5. The PHP Group may publish revised and/or new versions of the

license from time to time. Each version will be given a

distinguishing version number.

Once covered code has been published under a particular version

of the license, you may always continue to use it under the terms

of that version. You may also choose to use such covered code

under the terms of any subsequent version of the license

published by the PHP Group. No one other than the PHP Group has

the right to modify the terms applicable to covered code created

under this License.

6. Redistributions of any form whatsoever must retain the following

acknowledgment:

"This product includes PHP software, freely available from

<http://www.php.net/software/>".

THIS SOFTWARE IS PROVIDED BY THE PHP DEVELOPMENT TEAM ''AS IS'' AND

ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,

THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A

PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE PHP

DEVELOPMENT TEAM OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT,

INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES

(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR

SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)

HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,

STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)

ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED

OF THE POSSIBILITY OF SUCH DAMAGE.

--------------------------------------------------------------------

This software consists of voluntary contributions made by many

individuals on behalf of the PHP Group.

The PHP Group can be contacted via Email at group@php.net.

For more information on the PHP Group and the PHP project,

please see <http://www.php.net>.

PHP includes the Zend Engine, freely available at

<http://www.zend.com>.


PostgreSQL

PostgreSQL Database Management System

(formerly known as Postgres, then as Postgres95)

Portions Copyright (c) 1996-2010, The PostgreSQL Global Development Group

Portions Copyright (c) 1994, The Regents of the University of California

Permission to use, copy, modify, and distribute this software and its documentation for any purpose, without fee, and without a written agreement is hereby granted, provided that the above copyright notice and this paragraph and the following two paragraphs appear in all copies.

IN NO EVENT SHALL THE UNIVERSITY OF CALIFORNIA BE LIABLE TO ANY PARTY FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES, INCLUDING LOST PROFITS, ARISING OUT OF THE USE OF THIS SOFTWARE AND ITS DOCUMENTATION, EVEN IF THE UNIVERSITY OF CALIFORNIA HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

THE UNIVERSITY OF CALIFORNIA SPECIFICALLY DISCLAIMS ANY WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE SOFTWARE PROVIDED HEREUNDER IS ON AN "AS IS" BASIS, AND THE UNIVERSITY OF CALIFORNIA HAS NO OBLIGATIONS TO PROVIDE MAINTENANCE, SUPPORT, UPDATES, ENHANCEMENTS, OR MODIFICATIONS.


Redis

Three clause BSD license

Every file in the Redis distribution, with the exceptions of third party files specified in the list below, contain the following license:

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

•Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

•Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

•Neither the name of Redis nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


PostgreSQL JDBC Driver

Copyright (c) 1997, PostgreSQL Global Development Group

All rights reserved.

Redistribution and use in source and binary forms, with or without

modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice,

this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice,

this list of conditions and the following disclaimer in the documentation

and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"

AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE

IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE

ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE

LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR

CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF

SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS

INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN

CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)

ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE

POSSIBILITY OF SUCH DAMAGE.


Intel Integrated Performance Primitives, Math Kernel Library

Intel Simplified Software License (Version January 2018)

For: Intel(R) Math Kernel Library (Intel(R) MKL)

Intel(R) Integrated Performance Primitives (Intel(R) IPP)

Intel(R) Machine Learning Scaling Library (Intel(R) MLSL)

Intel(R) Data Analytics Acceleration Library (Intel(R) DAAL)

Intel(R) Threading Building Blocks (Intel(R) TBB)

Intel(R) Distribution for Python*

Intel(R) MPI Library

Copyright (c) 2018 Intel Corporation.

Use and Redistribution. You may use and redistribute the software (the “Software”), without modification, provided the following conditions are met:

* Redistributions must reproduce the above copyright notice and thefollowing terms of use in the Software and in the documentation and/or other materials provided with the distribution.

* Neither the name of Intel nor the names of its suppliers may be used toendorse or promote products derived from this Software without specific prior written permission.

* No reverse engineering, decompilation, or disassembly of this Software is permitted.

Limited patent license. Intel grants you a world-wide, royalty-free,

non-exclusive license under patents it now or hereafter owns or controls to

make, have made, use, import, offer to sell and sell (“Utilize”) this Software,

but solely to the extent that any such patent is necessary to Utilize the

Software alone. The patent license shall not apply to any combinations

which include this software. No hardware per se is licensed hereunder.

Third party and other Intel programs. “Third Party Programs” are the files listed in the “third-party-programs.txt” text file that is included with the Software and may include Intel programs under separate license terms. Third Party Programs, even if included with the distribution of the Materials, are governed by separate license terms and those license terms solely govern your use of those programs.

DISCLAIMER. THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, AND NON-INFRINGEMENT ARE DISCLAIMED. THIS SOFTWARE IS NOT INTENDED FOR USE IN SYSTEMS OR APPLICATIONS WHERE FAILURE OF THE SOFTWARE MAY CAUSE PERSONAL INJURY OR DEATH AND YOU AGREE THAT YOU ARE FULLY RESPONSIBLE FOR ANY CLAIMS, COSTS, DAMAGES, EXPENSES, AND ATTORNEYS’ FEES ARISING OUT OF ANY SUCH USE, EVEN IF ANY CLAIM ALLEGES THAT INTEL WAS NEGLIGENT REGARDING THE DESIGN OR MANUFACTURE OF THE MATERIALS.

LIMITATION OF LIABILITY. IN NO EVENT WILL INTEL BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. YOU AGREE TO INDEMNIFY AND HOLD INTEL HARMLESS AGAINST ANY CLAIMS AND EXPENSES RESULTING FROM YOUR USE OR UNAUTHORIZED USE OF THE SOFTWARE.

No support. Intel may make changes to the Software, at any time without notice, and is not obligated to support, update or provide training for the Software.

Termination. Intel may terminate your right to use the Software in the event of your breach of this Agreement and you fail to cure the breach within a reasonable period of time.

Feedback. Should you provide Intel with comments, modifications, corrections, enhancements or other input (“Feedback”) related to the Software Intel will be free to use, disclose, reproduce, license or otherwise distribute or exploit the Feedback in its sole discretion without any obligations or restrictions of any kind, including without limitation, intellectual property rights or licensing obligations.

Compliance with laws. You agree to comply with all relevant laws and regulations governing your use, transfer, import or export (or prohibition thereof) of the Software.

Governing law. All disputes will be governed by the laws of the United States of America and the State of Delaware without reference to conflict of law principles and subject to the exclusive jurisdiction of the state or federal courts sitting in the State of Delaware, and each party agrees that it submits to the personal jurisdiction and venue of those courts and waives any objections. The United Nations Convention on Contracts for the International Sale of Goods (1980) is specifically excluded and will not apply to the Software.

*Other names and brands may be claimed as the property of others.


Microsoft Public License (Ms-PL)

Published: October 12, 2006

This license governs use of the accompanying software. If you use the software, you accept this license. If you do not accept the license, do not use the software.

1. Definitions

The terms "reproduce," "reproduction," "derivative works," and "distribution" have the same meaning here as under U.S. copyright law.

A "contribution" is the original software, or any additions or changes to the software.

A "contributor" is any person that distributes its contribution under this license.

"Licensed patents" are a contributor’s patent claims that read directly on its contribution.

2. Grant of Rights

(A) Copyright Grant- Subject to the terms of this license, including the license conditions and limitations in section 3, each contributor grants you a non-exclusive, worldwide, royalty-free copyright license to reproduce its contribution, prepare derivative works of its contribution, and distribute its contribution or any derivative works that you create.

(B) Patent Grant- Subject to the terms of this license, including the license conditions and limitations in section 3, each contributor grants you a non-exclusive, worldwide, royalty-free license under its licensed patents to make, have made, use, sell, offer for sale, import, and/or otherwise dispose of its contribution in the software or derivative works of the contribution in the software.

3. Conditions and Limitations

(A) No Trademark License- This license does not grant you rights to use any contributors' name, logo, or trademarks.

(B) If you bring a patent claim against any contributor over patents that you claim are infringed by the software, your patent license from such contributor to the software ends automatically.

(C) If you distribute any portion of the software, you must retain all copyright, patent, trademark, and attribution notices that are present in the software.

(D) If you distribute any portion of the software in source code form, you may do so only under this license by including a complete copy of this license with your distribution. If you distribute any portion of the software in compiled or object code form, you may only do so under a license that complies with this license.

(E) The software is licensed "as-is." You bear the risk of using it. The contributors give no express warranties, guarantees or conditions. You may have additional consumer rights under your local laws which this license cannot change. To the extent permitted under your local laws, the contributors exclude the implied warranties of merchantability, fitness for a particular purpose and non-infringement.